aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/perf/perf_3.4.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/perf/perf_3.4.bbappend')
-rw-r--r--recipes-kernel/perf/perf_3.4.bbappend16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-kernel/perf/perf_3.4.bbappend b/recipes-kernel/perf/perf_3.4.bbappend
new file mode 100644
index 0000000..ce45f70
--- /dev/null
+++ b/recipes-kernel/perf/perf_3.4.bbappend
@@ -0,0 +1,16 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+PRINC := "${@int(PRINC) + 1}"
+
+# From OE-Core rev: 373371432b72cb19600a45e741afdfcb9662ecfb
+# We already pass the correct arguments to our compiler for the CFLAGS (if we
+# don't override it, it'll add -m32/-m64 itself). For LDFLAGS, it was failing
+# to find bfd symbols.
+EXTRA_OEMAKE += "\
+ 'CFLAGS=${CFLAGS}' \
+ 'LDFLAGS=${LDFLAGS} -lpthread -lrt -lelf -lm -lbfd' \
+"
+
+# From OE-Core rev: dce7918a818bf86fcc11f561af3eacaf281403d4
+do_configure_prepend () {
+ sed -i 's,-Werror ,,' ${S}/tools/perf/Makefile
+}