aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/systemd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/systemd')
-rw-r--r--recipes-core/systemd/systemd/10-dhcp.network5
-rw-r--r--recipes-core/systemd/systemd_213.bbappend7
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes-core/systemd/systemd/10-dhcp.network b/recipes-core/systemd/systemd/10-dhcp.network
new file mode 100644
index 0000000..aec1849
--- /dev/null
+++ b/recipes-core/systemd/systemd/10-dhcp.network
@@ -0,0 +1,5 @@
+[Match]
+Name=en*
+
+[Network]
+DHCP=yes
diff --git a/recipes-core/systemd/systemd_213.bbappend b/recipes-core/systemd/systemd_213.bbappend
new file mode 100644
index 0000000..0ba3368
--- /dev/null
+++ b/recipes-core/systemd/systemd_213.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append_minnow = " file://10-dhcp.network"
+
+do_install_append_minnow () {
+ install -m 0644 ${WORKDIR}/10-dhcp.network ${D}${sysconfdir}/systemd/network/dhcp.network
+}