aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/alsa-state/alsa-state.bbappend4
-rw-r--r--recipes-bsp/alsa-state/alsa-state/minnow/asound.state107
-rw-r--r--recipes-bsp/formfactor/formfactor/minnow/machconfig3
-rw-r--r--recipes-bsp/formfactor/formfactor_0.0.bbappend3
4 files changed, 117 insertions, 0 deletions
diff --git a/recipes-bsp/alsa-state/alsa-state.bbappend b/recipes-bsp/alsa-state/alsa-state.bbappend
new file mode 100644
index 0000000..48f32f5
--- /dev/null
+++ b/recipes-bsp/alsa-state/alsa-state.bbappend
@@ -0,0 +1,4 @@
+# Start with a known good alsa state for the Minnow board
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+PRINC := "${@int(PRINC) + 1}"
diff --git a/recipes-bsp/alsa-state/alsa-state/minnow/asound.state b/recipes-bsp/alsa-state/alsa-state/minnow/asound.state
new file mode 100644
index 0000000..9dfb0b1
--- /dev/null
+++ b/recipes-bsp/alsa-state/alsa-state/minnow/asound.state
@@ -0,0 +1,107 @@
+state.MID {
+ control.1 {
+ iface MIXER
+ name 'Capture Switch'
+ value.0 true
+ value.1 true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.2 {
+ iface MIXER
+ name 'Capture Volume'
+ value.0 25
+ value.1 25
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 31'
+ dbmin -1200
+ dbmax 3450
+ dbvalue.0 2550
+ dbvalue.1 2550
+ }
+ }
+ control.3 {
+ iface MIXER
+ name 'Front Playback Switch'
+ value.0 true
+ value.1 true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.4 {
+ iface MIXER
+ name 'Front Playback Volume'
+ value.0 27
+ value.1 27
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 30'
+ dbmin -4500
+ dbmax 0
+ dbvalue.0 -450
+ dbvalue.1 -450
+ }
+ }
+ control.5 {
+ iface MIXER
+ name 'Headphone Playback Switch'
+ value.0 true
+ value.1 true
+ comment {
+ access 'read write'
+ type BOOLEAN
+ count 2
+ }
+ }
+ control.6 {
+ iface MIXER
+ name 'Headphone Playback Volume'
+ value.0 0
+ value.1 0
+ comment {
+ access 'read write'
+ type INTEGER
+ count 2
+ range '0 - 3'
+ dbmin 0
+ dbmax 3000
+ dbvalue.0 0
+ dbvalue.1 0
+ }
+ }
+ control.7 {
+ iface PCM
+ name 'Playback Channel Map'
+ value.0 0
+ value.1 0
+ comment {
+ access read
+ type INTEGER
+ count 2
+ range '0 - 36'
+ }
+ }
+ control.8 {
+ iface PCM
+ name 'Capture Channel Map'
+ value.0 0
+ value.1 0
+ comment {
+ access read
+ type INTEGER
+ count 2
+ range '0 - 36'
+ }
+ }
+}
diff --git a/recipes-bsp/formfactor/formfactor/minnow/machconfig b/recipes-bsp/formfactor/formfactor/minnow/machconfig
new file mode 100644
index 0000000..ffce012
--- /dev/null
+++ b/recipes-bsp/formfactor/formfactor/minnow/machconfig
@@ -0,0 +1,3 @@
+# Assume a USB mouse and keyboard are connected
+HAVE_TOUCHSCREEN=0
+HAVE_KEYBOARD=1
diff --git a/recipes-bsp/formfactor/formfactor_0.0.bbappend b/recipes-bsp/formfactor/formfactor_0.0.bbappend
new file mode 100644
index 0000000..2a3ee7a
--- /dev/null
+++ b/recipes-bsp/formfactor/formfactor_0.0.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PRINC := "${@int(PRINC) + 2}"