aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-yocto_3.8.bb32
-rw-r--r--recipes-kernel/linux/linux-yocto_3.8.bbappend25
2 files changed, 25 insertions, 32 deletions
diff --git a/recipes-kernel/linux/linux-yocto_3.8.bb b/recipes-kernel/linux/linux-yocto_3.8.bb
deleted file mode 100644
index 9bed783..0000000
--- a/recipes-kernel/linux/linux-yocto_3.8.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-require recipes-kernel/linux/linux-yocto.inc
-
-KBRANCH_DEFAULT = "standard/minnow"
-KBRANCH = "${KBRANCH_DEFAULT}"
-KMETA = "meta"
-
-SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd \
- file://media.cfg"
-
-SRCREV_machine_pn-linux-yocto ?= "4afed227ab8d84c7eaf222cad85e8232e4ea9cb0"
-SRCREV_meta_pn-linux-yocto ?= "ad45d1d36de36b42cb8a3a8b34752a9b26ce6a68"
-SRCREV_emgd_pn-linux-yocto ?= "caea08c988e0f41103bbe18eafca20348f95da02"
-
-LINUX_VERSION ?= "3.8.13"
-
-PR = "${INC_PR}.1"
-PV = "${LINUX_VERSION}+git${SRCPV}"
-
-COMPATIBLE_MACHINE = "minnow"
-KMACHINE_minnow = "minnow"
-
-# Functionality flags
-KERNEL_FEATURES_minnow_append = " features/drm-emgd/drm-emgd-1.16 \
- features/netfilter/netfilter.scc \
- features/usb-net/usb-net.scc"
-
-# Autoload modules for on-board hardware
-module_autoload_snd_hda_intel = "snd_hda_intel"
-module_autoload_pch_gbe = "pch_gbe"
-module_autoload_minnowboard = "minnowboard"
-module_autoload_minnowboard-gpio = "minnowboard-gpio"
-module_autoload_minnowboard-keys = "minnowboard-keys"
diff --git a/recipes-kernel/linux/linux-yocto_3.8.bbappend b/recipes-kernel/linux/linux-yocto_3.8.bbappend
new file mode 100644
index 0000000..ccf6227
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_3.8.bbappend
@@ -0,0 +1,25 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+LINUX_VERSION = "3.8.13"
+
+KBRANCH_minnow = "standard/minnow"
+
+COMPATIBLE_MACHINE_minnow = "minnow"
+KMACHINE_minnow = "minnow"
+KERNEL_FEATURES_minnow_append = " features/drm-emgd/drm-emgd-1.16 \
+ features/netfilter/netfilter.scc \
+ features/usb-net/usb-net.scc"
+
+SRC_URI_minnow = "git://git.yoctoproject.org/linux-yocto-3.8;protocol=git;nocheckout=1;branch=${KBRANCH},${KMETA},emgd-1.16;name=machine,meta,emgd \
+ file://media.cfg"
+
+SRCREV_machine_pn-linux-yocto_minnow ?= "4afed227ab8d84c7eaf222cad85e8232e4ea9cb0"
+SRCREV_meta_pn-linux-yocto_minnow ?= "ad45d1d36de36b42cb8a3a8b34752a9b26ce6a68"
+SRCREV_emgd_pn-linux-yocto_minnow ?= "caea08c988e0f41103bbe18eafca20348f95da02"
+
+# Autoload modules for on-board hardware
+module_autoload_snd_hda_intel = "snd_hda_intel"
+module_autoload_pch_gbe = "pch_gbe"
+module_autoload_minnowboard = "minnowboard"
+module_autoload_minnowboard-gpio = "minnowboard-gpio"
+module_autoload_minnowboard-keys = "minnowboard-keys"