aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/diffutils/diffutils_%.bbappend6
-rw-r--r--recipes-extended/libarchive/libarchive_%.bbappend2
-rw-r--r--recipes-extended/libidn/libidn2_%.bbappend1
-rw-r--r--recipes-extended/zstd/zstd_%.bbappend2
4 files changed, 7 insertions, 4 deletions
diff --git a/recipes-extended/diffutils/diffutils_%.bbappend b/recipes-extended/diffutils/diffutils_%.bbappend
index 2c54a55..8b54cb0 100644
--- a/recipes-extended/diffutils/diffutils_%.bbappend
+++ b/recipes-extended/diffutils/diffutils_%.bbappend
@@ -1,9 +1,9 @@
-FILESEXTRAPATHS_prepend_mingw32 := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend:mingw32 := "${THISDIR}/${BPN}:"
# Add some definitions for POSIX signals..
-CFLAGS_append_mingw32 = " -DSIGALRM=14 -DSIGHUP=1 -DSIGQUIT=3 -DSIGPIPE=13 -DSIGTSTP=18 -DSIGSTOP=17 "
+CFLAGS:append:mingw32 = " -DSIGALRM=14 -DSIGHUP=1 -DSIGQUIT=3 -DSIGPIPE=13 -DSIGTSTP=18 -DSIGSTOP=17 "
-do_configure_prepend_mingw32 () {
+do_configure:prepend:mingw32 () {
# Remove building of "man" and "gnulib-tests". The tests don't
# cross-compile for mingw, but we aren't using them anyway
sed -i \
diff --git a/recipes-extended/libarchive/libarchive_%.bbappend b/recipes-extended/libarchive/libarchive_%.bbappend
index a411b40..228e85b 100644
--- a/recipes-extended/libarchive/libarchive_%.bbappend
+++ b/recipes-extended/libarchive/libarchive_%.bbappend
@@ -1 +1 @@
-EXTRA_OECONF_append_mingw32 = " --without-cng"
+EXTRA_OECONF:append:mingw32 = " --without-cng"
diff --git a/recipes-extended/libidn/libidn2_%.bbappend b/recipes-extended/libidn/libidn2_%.bbappend
new file mode 100644
index 0000000..51d0459
--- /dev/null
+++ b/recipes-extended/libidn/libidn2_%.bbappend
@@ -0,0 +1 @@
+FILES:${PN}-dev:append:mingw32 = " ${libdir}/*.def"
diff --git a/recipes-extended/zstd/zstd_%.bbappend b/recipes-extended/zstd/zstd_%.bbappend
new file mode 100644
index 0000000..11a2d4e
--- /dev/null
+++ b/recipes-extended/zstd/zstd_%.bbappend
@@ -0,0 +1,2 @@
+EXTRA_OEMAKE:append:mingw32 = " OS=Windows"
+FILES:${PN}:append:mingw32 = " ${libdir}/*.dll"