aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb')
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb
new file mode 100644
index 0000000..b12a04e
--- /dev/null
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-headers_2.0.8.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Header files from the MingGW-w64 project"
+LICENSE = "ZPL"
+LIC_FILES_CHKSUM = "file://../COPYING;md5=3194ff3a0d16f018784d1847bc6a3c4d"
+
+COMPATIBLE_HOST = ".*-mingw.*"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.gz \
+ file://epsilon.patch"
+
+SRC_URI[md5sum] = "659e5baf45ac8e8b8526f29786ee1112"
+SRC_URI[sha256sum] = "1a5a2c57f90c7f1b5eb8402a52f93de645925a8af62c2cfe748f39ce66008cf4"
+
+S = "${WORKDIR}/mingw-w64-v${PV}/mingw-w64-headers"
+B = "${WORKDIR}/build-${TARGET_SYS}"
+
+inherit autotools nativesdk
+
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS = ""
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ :
+}
+
+do_install_append() {
+ # Move files to include folder where gcc-crosssdk-initial is looking
+ mv ${D}${exec_prefix}/${HOST_SYS}/include ${D}${exec_prefix}
+ rmdir ${D}${exec_prefix}/${HOST_SYS}
+}