summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend3
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb7
-rw-r--r--recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb5
3 files changed, 2 insertions, 13 deletions
diff --git a/recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend b/recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend
deleted file mode 100644
index 135a776..0000000
--- a/recipes-devtools/gcc/gcc-crosssdk-initial_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-DEPENDS_append_mingw32 = " nativesdk-mingw-w64-headers"
-EXTRA_OECONF_remove_mingw32 = "--enable-initfini-array"
-EXTRA_OECONF_append_mingw32 = " --disable-initfini-array"
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
index fc83ca8..cf39c6a 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-runtime_6.0.0.bb
@@ -10,19 +10,14 @@ inherit autotools nativesdk
BUILDSDK_CPPFLAGS_append = " -isystem${STAGING_INCDIR}"
INHIBIT_DEFAULT_DEPS = "1"
-DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc-initial "
+DEPENDS = "nativesdk-mingw-w64-headers virtual/${TARGET_PREFIX}gcc "
PROVIDES += "virtual/nativesdk-libc"
-PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-initial"
-PROVIDES += "virtual/nativesdk-${SDK_PREFIX}libc-for-gcc"
# Work around pulling in eglibc for now...
PROVIDES += "virtual/nativesdk-libintl"
-STAGINGCC = "gcc-cross-initial-${TARGET_ARCH}"
-STAGINGCC_class-nativesdk = "gcc-crosssdk-initial-${SDK_SYS}"
TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
-PATH_prepend = "${STAGING_BINDIR_TOOLCHAIN}.${STAGINGCC}:"
do_configure() {
oe_runconf
diff --git a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
index b278ad7..e694e5b 100644
--- a/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
+++ b/recipes-devtools/mingw-w64/nativesdk-mingw-w64-winpthreads_6.0.0.bb
@@ -8,16 +8,13 @@ B = "${WORKDIR}/build-${TARGET_SYS}"
inherit autotools nativesdk
INHIBIT_DEFAULT_DEPS = "1"
-DEPENDS = "nativesdk-mingw-w64-runtime virtual/${TARGET_PREFIX}gcc-initial"
+DEPENDS = "nativesdk-mingw-w64-runtime virtual/${TARGET_PREFIX}gcc"
do_configure() {
oe_runconf
}
-STAGINGCC = "gcc-cross-initial-${TARGET_ARCH}"
-STAGINGCC_class-nativesdk = "gcc-crosssdk-initial-${SDK_SYS}"
TOOLCHAIN_OPTIONS = " --sysroot=${STAGING_DIR_TARGET}"
-PATH_prepend = "${STAGING_BINDIR_TOOLCHAIN}.${STAGINGCC}:"
do_install_append() {
# headers are already installed by mingw-w64-headers