aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-6/fix-llvm-libs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/openjdk/openjdk-6/fix-llvm-libs.patch')
-rw-r--r--recipes-core/openjdk/openjdk-6/fix-llvm-libs.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-6/fix-llvm-libs.patch b/recipes-core/openjdk/openjdk-6/fix-llvm-libs.patch
new file mode 100644
index 0000000..7c82daf
--- /dev/null
+++ b/recipes-core/openjdk/openjdk-6/fix-llvm-libs.patch
@@ -0,0 +1,13 @@
+Index: icedtea6-1.8/configure.ac
+===================================================================
+--- icedtea6-1.8.orig/configure.ac
++++ icedtea6-1.8/configure.ac
+@@ -472,7 +472,7 @@
+ if test "x$LLVM_SHARED_LIB" != x && echo "$flag" | grep -q '^-lLLVM'; then
+ continue
+ fi
+- if echo "$flag" | grep -q '^-l'; then
++ if echo "$flag" | grep -q '^-l\|.so'; then
+ if test "x$LLVM_LIBS" != "x"; then
+ LLVM_LIBS="$LLVM_LIBS "
+ fi