aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/llvm/llvm-common.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/llvm/llvm-common.bb')
-rw-r--r--recipes-core/llvm/llvm-common.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-core/llvm/llvm-common.bb b/recipes-core/llvm/llvm-common.bb
new file mode 100644
index 0000000..38ca1ee
--- /dev/null
+++ b/recipes-core/llvm/llvm-common.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Helper script for OE's llvm support"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
+ "
+
+SRC_URI = "file://llvm-config"
+
+do_install() {
+ install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+ install -m 0755 ${WORKDIR}/llvm-config ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+}
+
+do_install_virtclass-native() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
+}
+
+BBCLASSEXTEND = "native"