aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/junit/junit4_4.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/junit/junit4_4.3.1.bb')
-rw-r--r--recipes-core/junit/junit4_4.3.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-core/junit/junit4_4.3.1.bb b/recipes-core/junit/junit4_4.3.1.bb
new file mode 100644
index 0000000..bed0e42
--- /dev/null
+++ b/recipes-core/junit/junit4_4.3.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "JUnit is a testing framework for Java"
+LICENSE = "CPL"
+AUTHOR = "junit.org"
+HOMEPAGE = "http://www.junit.org"
+
+SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar"
+
+S = "${WORKDIR}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+ mkdir -p build
+
+ # Workaround for jamvm.
+ bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
+
+ javac -source 5.0 -bootclasspath $bcp -sourcepath . -d build `find . -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
+
+SRC_URI[md5sum] = "170f9645a41398388e8553b32ff5f630"
+SRC_URI[sha256sum] = "57d1e49ee3fd0dbdc0a68a852925c973af5c30b1725b6aa63bfb42df6f7c3349"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"