aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/jikes/jikes-initial.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/jikes/jikes-initial.bb')
-rw-r--r--recipes-core/jikes/jikes-initial.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-core/jikes/jikes-initial.bb b/recipes-core/jikes/jikes-initial.bb
new file mode 100644
index 0000000..613cb51
--- /dev/null
+++ b/recipes-core/jikes/jikes-initial.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Initial Java 1.4-compatible (and not higher) compiler"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+DEPENDS = "jikes-native classpath-initial"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ echo "#!/bin/sh" > jikes-initial
+ echo "${STAGING_BINDIR_NATIVE}/jikes -bootclasspath ${STAGING_DATADIR_NATIVE}/classpath-initial/glibj.zip \$@" >> jikes-initial
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 jikes-initial ${D}${bindir}
+}
+
+NATIVE_INSTALL_WORKS = "1"