aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/jamvm/jamvm/libffi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/jamvm/jamvm/libffi.patch')
-rw-r--r--recipes-core/jamvm/jamvm/libffi.patch38
1 files changed, 24 insertions, 14 deletions
diff --git a/recipes-core/jamvm/jamvm/libffi.patch b/recipes-core/jamvm/jamvm/libffi.patch
index 1f68c5e..36143d7 100644
--- a/recipes-core/jamvm/jamvm/libffi.patch
+++ b/recipes-core/jamvm/jamvm/libffi.patch
@@ -1,8 +1,17 @@
-Index: git/configure.ac
-===================================================================
---- git.orig/configure.ac 2011-11-18 15:47:15.339088111 +0100
-+++ git/configure.ac 2011-11-18 15:47:15.742392674 +0100
-@@ -273,9 +273,24 @@
+From fcd374ce67c0385ca94b09dfc1b1ddf13c3f631a Mon Sep 17 00:00:00 2001
+From: Henning Heinold <heinold@inf.fu-berlin.de>
+Date: Sat, 12 Nov 2011 20:58:34 +0100
+
+---
+ configure.ac | 27 ++++++++++++++++++++-------
+ src/Makefile.am | 5 +++--
+ 2 files changed, 23 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 138b7e6..cc1990a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -272,9 +272,24 @@ if test "$enable_zip" != no; then
AC_CHECK_LIB(z,inflate,,AC_MSG_ERROR(zlib is missing))
fi
@@ -29,7 +38,7 @@ Index: git/configure.ac
dnl Checks for header files.
AC_HEADER_STDC
-@@ -285,10 +300,6 @@
+@@ -284,10 +299,6 @@ if test "$enable_zip" != no; then
AC_CHECK_HEADER(zlib.h,,AC_MSG_ERROR(zlib.h is missing))
fi
@@ -40,7 +49,7 @@ Index: git/configure.ac
if test "$enable_zip" != no; then
AC_DEFINE([USE_ZIP],1,[use zip])
use_zip_yes=
-@@ -302,7 +313,9 @@
+@@ -301,7 +312,9 @@ AC_SUBST(use_zip_yes)
AC_SUBST(use_zip_no)
if test "$enable_ffi" != no; then
@@ -51,13 +60,13 @@ Index: git/configure.ac
fi
if test "$enable_md_stubs" != no; then
-Index: git/src/Makefile.am
-===================================================================
---- git.orig/src/Makefile.am 2011-11-18 15:47:15.685730049 +0100
-+++ git/src/Makefile.am 2011-11-18 15:49:43.881825251 +0100
-@@ -43,8 +43,9 @@
- jamvm_LDADD = libcore.la
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 1f06fed..9c39edb 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -44,9 +44,10 @@ jamvm_LDADD = libcore.la
libjvm_la_LIBADD = libcore.la
+ libjvm_la_LDFLAGS = -avoid-version
libcore_la_LIBADD = interp/libinterp.la os/@os@/@arch@/libnative.la \
- os/@os@/libos.la classlib/@classlib@/libclasslib.la
+ os/@os@/libos.la classlib/@classlib@/libclasslib.la \
@@ -66,4 +75,5 @@ Index: git/src/Makefile.am
-AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine
+AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine $(LIBFFI_CFLAGS)
- DISTCLEANFILES = arch.h classlib.h classlib-defs.h classlib-symbol.h
+ DISTCLEANFILES = arch.h classlib.h classlib-defs.h classlib-symbol.h \
+ classlib-excep.h