aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/classpathx/gnujaf_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/classpathx/gnujaf_1.1.1.bb')
-rw-r--r--recipes-core/classpathx/gnujaf_1.1.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-core/classpathx/gnujaf_1.1.1.bb b/recipes-core/classpathx/gnujaf_1.1.1.bb
new file mode 100644
index 0000000..2c055bb
--- /dev/null
+++ b/recipes-core/classpathx/gnujaf_1.1.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Provides a mean to type data and locate components suitable for performing various kinds of action on it."
+AUTHOR = "GNU ClasspathX"
+LICENSE = "GPL+libraryexception"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
+
+SRC_URI = "http://ftp.gnu.org/gnu/classpathx/activation-${PV}.tar.gz \
+ file://datadir_java.patch \
+ "
+
+inherit autotools java-library
+
+S = "${WORKDIR}/activation-${PV}"
+
+export JAVAC = "javac"
+
+# Fake javadoc
+export JAVADOC = "true"
+
+JARFILENAME = "activation-${PV}.jar"
+ALTJARFILENAMES = "activation.jar gnujaf.jar"
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath source -d build `find source -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
+
+SRC_URI[md5sum] = "de50d7728e8140eb404f2b4554321f8c"
+SRC_URI[sha256sum] = "b1b5ef560d30fcb11fbf537246857d14110ce4eb2b200d4c54690472305d87b7"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
+