aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/cacao')
-rw-r--r--recipes-core/cacao/cacao-initial-native_0.98.bb4
-rw-r--r--recipes-core/cacao/cacao/0001-java.in-Do-not-use-hardcode-paths.patch (renamed from recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch)33
-rw-r--r--recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch (renamed from recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch)21
-rw-r--r--recipes-core/cacao/cacao_git.bb (renamed from recipes-core/cacao/cacao_2d6f6c14daf9.bb)36
4 files changed, 55 insertions, 39 deletions
diff --git a/recipes-core/cacao/cacao-initial-native_0.98.bb b/recipes-core/cacao/cacao-initial-native_0.98.bb
index 8125e88..8432456 100644
--- a/recipes-core/cacao/cacao-initial-native_0.98.bb
+++ b/recipes-core/cacao/cacao-initial-native_0.98.bb
@@ -6,7 +6,7 @@ SECTION = "interpreters"
PROVIDES = "virtual/java-initial-native"
-inherit native autotools-brokensep
+inherit autotools-brokensep native
DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial-native jikes-initial-native"
@@ -35,7 +35,7 @@ export JAVAC="jikes-initial"
# enforces the usage of fastjar
export JAR="fastjar"
-do_configure_append() {
+do_configure:append() {
# Fix the executable name in the wrapper script.
sed -i -e "s|exec cacao \\$|exec cacao-initial \\$|" src/scripts/java.in
}
diff --git a/recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch b/recipes-core/cacao/cacao/0001-java.in-Do-not-use-hardcode-paths.patch
index 665377b..521814e 100644
--- a/recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch
+++ b/recipes-core/cacao/cacao/0001-java.in-Do-not-use-hardcode-paths.patch
@@ -1,25 +1,31 @@
-java.in: Do not use hardcode paths
+From 51a63cdac93caf69d1b6ace40f73f6147ba37de5 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Erkka=20K=C3=A4=C3=A4ri=C3=A4?= <erkka.kaaria@intel.com>
+Date: Thu, 20 Aug 2020 13:48:38 +0200
+Subject: [PATCH 1/2] java.in: Do not use hardcode paths
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
Cacao uses hardcoded paths to various files, if these paths are not
provided. This causes issues when sharing sstate with otherwise
identical workers, if build time paths are not identical.
-Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com>
-
Upstream-Status: Inappropriate [Yocto-specific fixes]
+Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com>
+Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
---
- cacao-1.6.1/src/scripts/java.in | 16 ++++++++++++++--
- 1 file changed, 14 insertions(+), 2 deletions(-)
+ src/scripts/java.in | 15 +++++++++++++--
+ 1 file changed, 13 insertions(+), 2 deletions(-)
-diff --git cacao-1.6.1/src/scripts/java.in cacao-1.6.1/src/scripts/java.in
-index 0790f02..2118de7 100644
---- cacao-1.6.1/src/scripts/java.in
-+++ cacao-1.6.1/src/scripts/java.in
-@@ -22,5 +22,17 @@
+diff --git a/src/scripts/java.in b/src/scripts/java.in
+index 0790f0255..a4f16ecdc 100644
+--- a/src/scripts/java.in
++++ b/src/scripts/java.in
+@@ -22,5 +22,16 @@
## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
## 02110-1301, USA.
-
+
-IFS=""
-exec $(dirname ${0})/cacao ${1+"$@"}
+SH_DIR=`dirname "$0"`
@@ -35,7 +41,6 @@ index 0790f02..2118de7 100644
+export BOOTCLASSPATH="${PARENT_DIR}/share/cacao/vm.zip:${PARENT_DIR}/share/classpath/glibj.zip"
+LIBRARY_PATH="-Djava.library.path=${PARENT_DIR}/lib/classpath"
+exec ${REAL_DIR}/cacao ${LIBRARY_PATH} ${1+"$@"}
-+
---
-2.7.4
+--
+2.28.0
diff --git a/recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch b/recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch
index c30f5be..102e9a7 100644
--- a/recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch
+++ b/recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch
@@ -1,4 +1,7 @@
-cacao: use system's boehm garbage collector
+From 7833101c8c8938d58a32e355b9af1b56e4229a87 Mon Sep 17 00:00:00 2001
+From: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
+Date: Thu, 20 Aug 2020 13:50:47 +0200
+Subject: [PATCH 2/2] cacao: use system's boehm garbage collector
This is a Gentoo's patch [1] to force the use of system's bdwgc.
@@ -10,11 +13,17 @@ with the system's version.
Upstream-Status: Inappropriate [not author]
Signed-off-by: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
+Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
+---
+ configure.ac | 8 ++------
+ src/mm/Makefile.am | 9 ++++-----
+ 2 files changed, 6 insertions(+), 11 deletions(-)
diff --git a/configure.ac b/configure.ac
+index aceb2033b..db8a9770e 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -691,6 +691,8 @@
+@@ -738,6 +738,8 @@ AC_CHECK_ENABLE_GCC_PR40134
AC_CHECK_ENABLE_PIC_ASM
@@ -23,7 +32,7 @@ diff --git a/configure.ac b/configure.ac
dnl Define version numbers.
AC_VERSION_DETAIL
AC_VERSION_CONFIG
-@@ -793,12 +795,6 @@
+@@ -855,12 +857,6 @@ AC_CONFIG_FILES([Makefile]
)
@@ -37,9 +46,10 @@ diff --git a/configure.ac b/configure.ac
diff --git a/src/mm/Makefile.am b/src/mm/Makefile.am
+index 9d0945a29..cbd7dc963 100644
--- a/src/mm/Makefile.am
+++ b/src/mm/Makefile.am
-@@ -35,14 +35,13 @@
+@@ -35,14 +35,13 @@ GC_FILE = \
endif
if ENABLE_GC_BOEHM
@@ -58,3 +68,6 @@ diff --git a/src/mm/Makefile.am b/src/mm/Makefile.am
endif
if ENABLE_GC_CACAO
+--
+2.28.0
+
diff --git a/recipes-core/cacao/cacao_2d6f6c14daf9.bb b/recipes-core/cacao/cacao_git.bb
index 0e50b68..fef7f34 100644
--- a/recipes-core/cacao/cacao_2d6f6c14daf9.bb
+++ b/recipes-core/cacao/cacao_git.bb
@@ -4,27 +4,25 @@ LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
SECTION = "interpreters"
-DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-initial-native classpath-native bdwgc-native virtual/java-initial-native"
-PROVIDES_class-native = "virtual/java-native"
+DEPENDS:class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-initial-native classpath-native bdwgc-native virtual/java-initial-native"
+PROVIDES:class-native = "virtual/java-native"
DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc"
-RPROVIDES_${PN} = "java2-runtime"
+RPROVIDES:${PN} = "java2-runtime"
-SRC_URI = "https://bitbucket.org/cacaovm/cacao-staging/get/${PV}.zip \
- file://system-boehm-gc.patch \
- file://cacao-1.6.1-do-not-rely-on-absolute-paths.patch \
+SRCREV = "6c4694f9bd175386a8c451531e9a5ad97aa23b6f"
+SRC_URI = "git://bitbucket.org/cacaovm/cacao.git;protocol=https;branch=master \
+ file://0001-java.in-Do-not-use-hardcode-paths.patch \
+ file://0002-cacao-use-system-s-boehm-garbage-collector.patch \
"
-S = "${WORKDIR}/cacaovm-cacao-staging-${PV}"
-
-SRC_URI[md5sum] = "5157d0bb9eb1332f7a6b6186eaac01aa"
-SRC_URI[sha256sum] = "34b51d660d69c2a83225fd75eab5e1fac002fb5974cb4a74b7478baf923a76cd"
+S = "${WORKDIR}/git"
inherit java autotools-brokensep update-alternatives pkgconfig features_check
REQUIRED_DISTRO_FEATURES = "x11"
-REQUIRED_DISTRO_FEATURES_class-native := ""
+REQUIRED_DISTRO_FEATURES:class-native := ""
-EXTRA_OECONF_class-native = "\
+EXTRA_OECONF:class-native = "\
--enable-debug \
--with-vm-zip=${datadir}/cacao/vm.zip \
--with-java-runtime-library-classes=${datadir}/classpath/glibj.zip \
@@ -35,7 +33,7 @@ EXTRA_OECONF_class-native = "\
--disable-libjvm \
"
-CACHED_CONFIGUREVARS_class-native += "ac_cv_prog_JAVAC=${STAGING_BINDIR_NATIVE}/ecj-initial"
+CACHED_CONFIGUREVARS:class-native += "ac_cv_prog_JAVAC=${STAGING_BINDIR_NATIVE}/ecj-initial"
EXTRA_OECONF = "\
--with-vm-zip=${datadir}/cacao/vm.zip \
@@ -48,21 +46,21 @@ EXTRA_OECONF = "\
--disable-test-dependency-checks \
"
-do_configure_prepend () {
+do_configure:prepend () {
# upgrade m4 macros in source tree
libtoolize --force --copy --install
rm -f src/mm/boehm-gc/ltmain.sh
mkdir -p src/mm/boehm-gc/m4
}
-do_install_append_class-target() {
+do_install:append:class-target() {
rm ${D}/${bindir}/java
}
-FILES_${PN} = "${bindir}/${PN} ${libdir}/cacao/lib*.so ${libdir}/lib*.so* ${datadir}/${PN}"
-FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug/lib*.so*"
-FILES_${PN}-doc += "${datadir}/gc"
+FILES:${PN} = "${bindir}/${PN} ${libdir}/cacao/lib*.so ${libdir}/lib*.so* ${datadir}/${PN}"
+FILES:${PN}-dbg += "${bindir}/.debug ${libdir}/.debug/lib*.so*"
+FILES:${PN}-doc += "${datadir}/gc"
BBCLASSEXTEND = "native"
-COMPATIBLE_MACHINE_aarch64 = "-"
+COMPATIBLE_MACHINE:aarch64 = "-"