aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/java-library.bbclass8
-rw-r--r--recipes-core/libmatthew/libmatthew.inc1
-rw-r--r--recipes-extended/rxtx/rxtx_2.2.0.bb1
3 files changed, 7 insertions, 3 deletions
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass
index a74c8d3..144cd2f 100644
--- a/classes/java-library.bbclass
+++ b/classes/java-library.bbclass
@@ -7,8 +7,12 @@
# starts with "lib" and/or ends with "-java". In case the "lib" prefix is part of
# your package's normal name (e.g. liberator) the guessing is wrong and you have
# to set JPN manually!
+#
+# package archs are set to all, if the recipe builds also packages which
+# can not be used for all archs, then set the PACKAGE_ARCH of that package
+# manually, see rxtx_xx.bb for an example.
-inherit java
+inherit java allarch
# use java_stage for native packages
JAVA_NATIVE_STAGE_INSTALL = "1"
@@ -35,8 +39,6 @@ DEPENDS_prepend = "virtual/javac-native fastjar-native "
PACKAGES += "${JPN}"
-PACKAGE_ARCH_${JPN} = "all"
-
FILES_${JPN} = "${datadir_java}"
# File name of the libraries' main Jar file
diff --git a/recipes-core/libmatthew/libmatthew.inc b/recipes-core/libmatthew/libmatthew.inc
index b7e50bd..36622a8 100644
--- a/recipes-core/libmatthew/libmatthew.inc
+++ b/recipes-core/libmatthew/libmatthew.inc
@@ -8,6 +8,7 @@ DEPENDS = "virtual/java-native classpath-native classpath"
S = "${WORKDIR}/libmatthew-java-${PV}"
inherit java-library
+PACKAGE_ARCH = "${TUNE_PKGARCH}"
# Some internal version numbers which change from time to time.
# Allowing to override them makes this include file more
diff --git a/recipes-extended/rxtx/rxtx_2.2.0.bb b/recipes-extended/rxtx/rxtx_2.2.0.bb
index 85f55c0..0d5aa21 100644
--- a/recipes-extended/rxtx/rxtx_2.2.0.bb
+++ b/recipes-extended/rxtx/rxtx_2.2.0.bb
@@ -23,6 +23,7 @@ S = "${WORKDIR}/rxtx-2.2pre2"
INSANE_SKIP_${PN} += "dev-so"
inherit autotools-brokensep java-library
+PACKAGE_ARCH = "${TUNE_PKGARCH}"
JARFILENAME = "RXTXcomm.jar"
EXTRA_OEMAKE += "RXTX_PATH=${D}${libdir_jni} \