aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/java-library.bbclass8
-rw-r--r--recipes-core/libmatthew/libmatthew.inc2
-rw-r--r--recipes-extended/rxtx/rxtx_2.2.0.bb2
3 files changed, 8 insertions, 4 deletions
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass
index ce1cd28..e0159ba 100644
--- a/classes/java-library.bbclass
+++ b/classes/java-library.bbclass
@@ -10,9 +10,13 @@
#
# package archs are set to all, if the recipe builds also packages which
# can not be used for all archs, then set the PACKAGE_ARCH of that package
-# manually, see rxtx_xx.bb for an example.
+# manually *before* inheriting the class, see rxtx_xx.bb for an example.
-inherit java allarch
+inherit java
+PACKAGE_ARCH ?= "all"
+# Fully expanded - so it applies the overrides as well
+PACKAGE_ARCH_EXPANDED := "${PACKAGE_ARCH}"
+inherit ${@oe.utils.ifelse(d.getVar('PACKAGE_ARCH_EXPANDED') == 'all', 'allarch', '')}
# use java_stage for native packages
JAVA_NATIVE_STAGE_INSTALL = "1"
diff --git a/recipes-core/libmatthew/libmatthew.inc b/recipes-core/libmatthew/libmatthew.inc
index 7db979b..2119c0b 100644
--- a/recipes-core/libmatthew/libmatthew.inc
+++ b/recipes-core/libmatthew/libmatthew.inc
@@ -7,8 +7,8 @@ DEPENDS = "virtual/java-native classpath-native classpath"
S = "${WORKDIR}/libmatthew-java-${PV}"
-inherit java-library
PACKAGE_ARCH = "${TUNE_PKGARCH}"
+inherit java-library
# Some internal version numbers which change from time to time.
# Allowing to override them makes this include file more
diff --git a/recipes-extended/rxtx/rxtx_2.2.0.bb b/recipes-extended/rxtx/rxtx_2.2.0.bb
index e54dad7..d4fbb9d 100644
--- a/recipes-extended/rxtx/rxtx_2.2.0.bb
+++ b/recipes-extended/rxtx/rxtx_2.2.0.bb
@@ -28,8 +28,8 @@ S = "${WORKDIR}/rxtx-2.2pre2"
INSANE_SKIP_${JPN} += "dev-so"
-inherit autotools-brokensep java-library remove-libtool
PACKAGE_ARCH = "${TUNE_PKGARCH}"
+inherit autotools-brokensep java-library remove-libtool
JARFILENAME = "RXTXcomm.jar"
EXTRA_OEMAKE += "RXTX_PATH=${D}${libdir_jni} \