aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/cacao/cacao_1.6.1.bb4
-rw-r--r--recipes-core/classpath/classpath.inc4
-rw-r--r--recipes-core/jamvm/jamvm.inc4
-rw-r--r--recipes-core/openjdk/openjdk-common.inc4
4 files changed, 12 insertions, 4 deletions
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb
index 14ff019..d52f339 100644
--- a/recipes-core/cacao/cacao_1.6.1.bb
+++ b/recipes-core/cacao/cacao_1.6.1.bb
@@ -15,7 +15,9 @@ SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-
SRC_URI[md5sum] = "2c18478404afd1cffdd15ad1e9d85a57"
SRC_URI[sha256sum] = "eecc8bd1b528a028f43d9d1d0c06b97855bbf1d40e03826d911ebbc0b6971e12"
-inherit java autotools-brokensep update-alternatives pkgconfig
+inherit java autotools-brokensep update-alternatives pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
EXTRA_OECONF_class-native = "\
--enable-debug \
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index 1bdfd78..0f760fe 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -7,7 +7,9 @@ LICENSE = "Classpath"
PBN = "classpath"
-inherit autotools java gettext
+inherit autotools java gettext distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file"
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index bed1c5d..9d9fef6 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -21,7 +21,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \
"
-inherit java autotools update-alternatives pkgconfig
+inherit java autotools update-alternatives pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
# This uses 32 bit arm, so force the instruction set to arm, not thumb
ARM_INSTRUCTION_SET = "arm"
diff --git a/recipes-core/openjdk/openjdk-common.inc b/recipes-core/openjdk/openjdk-common.inc
index dc26522..e3e597a 100644
--- a/recipes-core/openjdk/openjdk-common.inc
+++ b/recipes-core/openjdk/openjdk-common.inc
@@ -17,7 +17,9 @@ DEPENDS_append_libc-uclibc = " virtual/libiconv "
# because structure sizes and/or alignment may differ.
DEPENDS_append = " qemu-native "
-inherit java autotools gettext qemu pkgconfig
+inherit java autotools gettext qemu pkgconfig distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "x11"
# OpenJDK uses slightly different names for certain arches. We need to know
# this to create some files which are expected by the build.