aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/xml-commons/xom_1.2.10.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes-core/xml-commons/xom_1.2.10.bb b/recipes-core/xml-commons/xom_1.2.10.bb
index 8755ddc..8b43c39 100644
--- a/recipes-core/xml-commons/xom_1.2.10.bb
+++ b/recipes-core/xml-commons/xom_1.2.10.bb
@@ -28,14 +28,22 @@ inherit java-library
DEPENDS = "fastjar-native virtual/javac-native xerces-j xalan-j"
+do_move_jaxen() {
+ if [ -d ${WORKDIR}/git ] ; then
+ mv ${WORKDIR}/git/jaxen ${WORKDIR}/jaxen-${PV_jaxen}
+ rm -rf ${WORKDIR}/git
+ fi
+
+}
+
+addtask move_jaxen after do_removebinaries before do_patch
+
do_compile() {
mkdir -p build
oe_makeclasspath cp -s xercesImpl xalan2
cp=build:$cp
- mv ${WORKDIR}/git/jaxen ${WORKDIR}/jaxen-${PV_jaxen}
- rm -rf ${WORKDIR}/git
scp="${WORKDIR}/jaxen-${PV_jaxen}/src/java/main"
javac -sourcepath src:$scp -cp $cp -d build `find src -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)`