aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/java-bootstrap-components.bbclass7
-rw-r--r--classes/java-library.bbclass3
-rw-r--r--recipes-core/ant/ant-native_1.8.1.bb2
-rw-r--r--recipes-core/cacao/cacao_1.6.1.bb4
-rw-r--r--recipes-core/classpath/classpath.inc4
-rw-r--r--recipes-core/classpathx/gnujaf_1.1.1.bb2
-rw-r--r--recipes-core/classpathx/gnumail_1.1.2.bb2
-rw-r--r--recipes-core/classpathx/inetlib_1.1.1.bb2
-rw-r--r--recipes-core/ecj/ecj-bootstrap-native.bb2
-rw-r--r--recipes-core/ecj/libecj-bootstrap.inc2
-rw-r--r--recipes-core/icedtea/icedtea7-native.inc2
-rw-r--r--recipes-core/jacl/jacl_1.4.1.bb2
-rw-r--r--recipes-core/jakarta-commons/commons-logging_1.1.1.bb2
-rw-r--r--recipes-core/jakarta-commons/commons-net_1.4.1.bb2
-rw-r--r--recipes-core/jakarta-libs/avalon-framework-api_4.3.bb2
-rw-r--r--recipes-core/jakarta-libs/bsf_2.4.0.bb2
-rw-r--r--recipes-core/jakarta-libs/log4j1.2_1.2.17.bb2
-rw-r--r--recipes-core/jakarta-libs/logkit_1.2.2.bb2
-rw-r--r--recipes-core/jakarta-libs/oro_2.0.8.bb2
-rw-r--r--recipes-core/jakarta-libs/poi_3.0.bb2
-rw-r--r--recipes-core/jakarta-libs/regexp_1.5.bb2
-rw-r--r--recipes-core/jamvm/jamvm.inc4
-rw-r--r--recipes-core/jcraft/jsch_0.1.40.bb2
-rw-r--r--recipes-core/jcraft/jzlib_1.0.7.bb2
-rw-r--r--recipes-core/jdepend/jdepend_2.9.1.bb2
-rw-r--r--recipes-core/jlex/jlex_1.2.6.bb2
-rw-r--r--recipes-core/junit/junit4_4.3.1.bb4
-rw-r--r--recipes-core/junit/junit_3.8.2.bb2
-rw-r--r--recipes-core/rhino/rhino_1.7r4.bb2
-rw-r--r--recipes-core/servlet-api/servlet2.3_4.1.37.bb4
-rw-r--r--recipes-core/servlet-api/servlet2.4_5.5.26.bb2
-rw-r--r--recipes-core/xalan-j/xalan-j_2.7.1.bb2
-rw-r--r--recipes-core/xerces-j/xerces-j_2.11.0.bb6
-rw-r--r--recipes-core/xml-commons/jaxp1.3_1.4.01.bb4
-rw-r--r--recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb6
-rw-r--r--recipes-core/xml-commons/xpp2_2.1.10.bb2
-rw-r--r--recipes-core/xml-commons/xpp3_1.1.3.4.O.bb2
37 files changed, 51 insertions, 49 deletions
diff --git a/classes/java-bootstrap-components.bbclass b/classes/java-bootstrap-components.bbclass
new file mode 100644
index 0000000..0c62b5b
--- /dev/null
+++ b/classes/java-bootstrap-components.bbclass
@@ -0,0 +1,7 @@
+# This is to be used by recipes which rely on java-library.bbclass
+# infrastructure and their a *-native recipe are parts of the bootstrap
+# process
+#
+
+DEPENDS_prepend_class-native = " ecj-bootstrap-native "
+DEPENDS_prepend_class-target = " virtual/javac-native "
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass
index 144cd2f..a192f14 100644
--- a/classes/java-library.bbclass
+++ b/classes/java-library.bbclass
@@ -35,7 +35,8 @@ def java_package_name(d):
JPN ?= "${@java_package_name(d)}"
-DEPENDS_prepend = "virtual/javac-native fastjar-native "
+DEPENDS_prepend = " fastjar-native "
+DEPENDS_prepend_class-target = " virtual/javac-native "
PACKAGES += "${JPN}"
diff --git a/recipes-core/ant/ant-native_1.8.1.bb b/recipes-core/ant/ant-native_1.8.1.bb
index 35b45d6..6cdbc80 100644
--- a/recipes-core/ant/ant-native_1.8.1.bb
+++ b/recipes-core/ant/ant-native_1.8.1.bb
@@ -11,7 +11,7 @@ SRC_URI = "http://archive.apache.org/dist/ant/source/apache-ant-${PV}-src.tar.gz
S = "${WORKDIR}/apache-ant-${PV}"
-inherit java-library java-native
+inherit java-library java-native java-bootstrap-components
DEPENDS = " \
jsch-native bsf-native xalan-j-native xerces-j-native \
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb
index 8e212af..a8c1f19 100644
--- a/recipes-core/cacao/cacao_1.6.1.bb
+++ b/recipes-core/cacao/cacao_1.6.1.bb
@@ -7,7 +7,9 @@ SECTION = "interpreters"
DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-native bdwgc-native"
PROVIDES_class-native = "virtual/java-native"
-DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc"
+DEPENDS_class-target = " virtual/javac-native "
+
+DEPENDS = "zlib libtool classpath bdwgc"
RPROVIDES_${PN} = "java2-runtime"
SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.xz \
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index 1bdfd78..c56c0c3 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -7,9 +7,9 @@ LICENSE = "Classpath"
PBN = "classpath"
-inherit autotools java gettext
+inherit autotools java gettext java-bootstrap-components
-DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file"
+DEPENDS = " fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file"
RPROVIDES_${PN} = ""
diff --git a/recipes-core/classpathx/gnujaf_1.1.1.bb b/recipes-core/classpathx/gnujaf_1.1.1.bb
index 0bd8b57..5520ef7 100644
--- a/recipes-core/classpathx/gnujaf_1.1.1.bb
+++ b/recipes-core/classpathx/gnujaf_1.1.1.bb
@@ -10,7 +10,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/classpathx/activation-${PV}.tar.gz \
file://MimeType-symbols-fix.patch \
"
-inherit java-library
+inherit java-library java-bootstrap-components
S = "${WORKDIR}/activation-${PV}"
diff --git a/recipes-core/classpathx/gnumail_1.1.2.bb b/recipes-core/classpathx/gnumail_1.1.2.bb
index 5e81a45..41417c0 100644
--- a/recipes-core/classpathx/gnumail_1.1.2.bb
+++ b/recipes-core/classpathx/gnumail_1.1.2.bb
@@ -8,7 +8,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/classpathx/mail-${PV}.tar.gz \
file://datadir_java.patch \
"
-inherit java-library autotools
+inherit java-library java-bootstrap-components autotools
S = "${WORKDIR}/mail-${PV}"
diff --git a/recipes-core/classpathx/inetlib_1.1.1.bb b/recipes-core/classpathx/inetlib_1.1.1.bb
index f078e33..3b3f299 100644
--- a/recipes-core/classpathx/inetlib_1.1.1.bb
+++ b/recipes-core/classpathx/inetlib_1.1.1.bb
@@ -9,7 +9,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/classpath/${BP}.tar.gz \
file://datadir_java.patch \
"
-inherit java-library autotools
+inherit java-library java-bootstrap-components autotools
JPN = "libgnuinet-java"
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb
index e159c9d..a4a1c17 100644
--- a/recipes-core/ecj/ecj-bootstrap-native.bb
+++ b/recipes-core/ecj/ecj-bootstrap-native.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
"
PR = "r1"
-DEPENDS = "libecj-bootstrap-native virtual/java-native"
+DEPENDS = "libecj-bootstrap-native cacao-native"
PROVIDES = "virtual/javac-native"
diff --git a/recipes-core/ecj/libecj-bootstrap.inc b/recipes-core/ecj/libecj-bootstrap.inc
index 020b8d3..a634a31 100644
--- a/recipes-core/ecj/libecj-bootstrap.inc
+++ b/recipes-core/ecj/libecj-bootstrap.inc
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.eclipse.org/"
LICENSE = "EPL-1.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6"
-DEPENDS = "fastjar-native jikes-initial-native virtual/java-initial-native"
+DEPENDS = "fastjar-native jikes-initial-native cacao-initial-native"
INC_PR = "r5"
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc
index 43385e9..279700b 100644
--- a/recipes-core/icedtea/icedtea7-native.inc
+++ b/recipes-core/icedtea/icedtea7-native.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://icedtea.classpath.org"
LICENSE = "GPL-2.0-with-classpath-exception"
INC_PR = "r1"
-DEPENDS = "virtual/javac-native virtual/java-native classpath-native \
+DEPENDS = "fastjar-native cacao-native classpath-native \
rhino-native ant-native libxslt-native attr-native \
giflib-native jpeg-native libpng-native \
glib-2.0-native freetype-native zlib-native \
diff --git a/recipes-core/jacl/jacl_1.4.1.bb b/recipes-core/jacl/jacl_1.4.1.bb
index b413719..f9808ca 100644
--- a/recipes-core/jacl/jacl_1.4.1.bb
+++ b/recipes-core/jacl/jacl_1.4.1.bb
@@ -10,7 +10,7 @@ HOMEPAGE = "http://sourceforge.net/projects/tcljava"
SRC_URI = "http://downloads.sourceforge.net/tcljava/jacl${PV}.tar.gz"
-inherit java-library
+inherit java-library java-bootstrap-components
S = "${WORKDIR}/jacl${PV}"
diff --git a/recipes-core/jakarta-commons/commons-logging_1.1.1.bb b/recipes-core/jakarta-commons/commons-logging_1.1.1.bb
index b3b508a..8b1efe0 100644
--- a/recipes-core/jakarta-commons/commons-logging_1.1.1.bb
+++ b/recipes-core/jakarta-commons/commons-logging_1.1.1.bb
@@ -1,5 +1,7 @@
require jakarta-commons.inc
+inherit java-bootstrap-components
+
PR = "${INC_PR}.1"
DESCRIPTION = "Java Internet protocol suite library"
diff --git a/recipes-core/jakarta-commons/commons-net_1.4.1.bb b/recipes-core/jakarta-commons/commons-net_1.4.1.bb
index 275ebb9..7c03b82 100644
--- a/recipes-core/jakarta-commons/commons-net_1.4.1.bb
+++ b/recipes-core/jakarta-commons/commons-net_1.4.1.bb
@@ -1,5 +1,7 @@
require jakarta-commons.inc
+inherit java-bootstrap-components
+
PR = "${INC_PR}.1"
DESCRIPTION = "Java Internet protocol suite library"
diff --git a/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb b/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb
index 081cfe7..2e2bb59 100644
--- a/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb
+++ b/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
http://archive.apache.org/dist/avalon/logkit/source/logkit-1.2.2-src.tar.gz;name=logkit \
"
-inherit java-library
+inherit java-library java-bootstrap-components
do_compile() {
mkdir -p build
diff --git a/recipes-core/jakarta-libs/bsf_2.4.0.bb b/recipes-core/jakarta-libs/bsf_2.4.0.bb
index 0213004..e23503c 100644
--- a/recipes-core/jakarta-libs/bsf_2.4.0.bb
+++ b/recipes-core/jakarta-libs/bsf_2.4.0.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b1e01b26bacfc2232046c90a330332b3"
SRC_URI = "http://archive.apache.org/dist/jakarta/bsf/source/bsf-src-${PV}.tar.gz"
-inherit java-library
+inherit java-library java-bootstrap-components
DEPENDS = "jacl commons-logging rhino xalan-j bcel"
DEPENDS_virtclass-native = "jacl-native commons-logging-native rhino-native xalan-j-native bcel-native"
diff --git a/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb
index b4ccd2c..50ef4a2 100644
--- a/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb
+++ b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb
@@ -7,7 +7,7 @@ PR = "r2"
SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/log4j-${PV}.tar.gz"
-inherit java-library
+inherit java-library java-bootstrap-components
DEPENDS = "gnumail gnujaf"
DEPENDS_virtclass-native = "gnumail-native gnujaf-native"
diff --git a/recipes-core/jakarta-libs/logkit_1.2.2.bb b/recipes-core/jakarta-libs/logkit_1.2.2.bb
index c3b612b..24fdfac 100644
--- a/recipes-core/jakarta-libs/logkit_1.2.2.bb
+++ b/recipes-core/jakarta-libs/logkit_1.2.2.bb
@@ -6,7 +6,7 @@ PR = "r1"
SRC_URI = "http://archive.apache.org/dist/avalon/logkit/source/${BP}-src.tar.gz"
-inherit java-library
+inherit java-library java-bootstrap-components
S = "${WORKDIR}/${BP}-dev"
diff --git a/recipes-core/jakarta-libs/oro_2.0.8.bb b/recipes-core/jakarta-libs/oro_2.0.8.bb
index 0a7fba3..308eb55 100644
--- a/recipes-core/jakarta-libs/oro_2.0.8.bb
+++ b/recipes-core/jakarta-libs/oro_2.0.8.bb
@@ -6,7 +6,7 @@ PR = "r1"
SRC_URI = "http://archive.apache.org/dist/jakarta/oro/source/jakarta-${BP}.tar.gz"
-inherit java-library
+inherit java-library java-bootstrap-components
S = "${WORKDIR}/jakarta-${BP}"
diff --git a/recipes-core/jakarta-libs/poi_3.0.bb b/recipes-core/jakarta-libs/poi_3.0.bb
index f9178f2..55279c1 100644
--- a/recipes-core/jakarta-libs/poi_3.0.bb
+++ b/recipes-core/jakarta-libs/poi_3.0.bb
@@ -9,7 +9,7 @@ S = "${WORKDIR}/${BPN}-3.0-rc4"
inherit java-library
-DEPENDS = "fastjar-native commons-collections3 commons-logging commons-lang commons-beanutils log4j1.2 xalan-j"
+DEPENDS = "commons-collections3 commons-logging commons-lang commons-beanutils log4j1.2 xalan-j"
do_compile() {
mkdir -p build
diff --git a/recipes-core/jakarta-libs/regexp_1.5.bb b/recipes-core/jakarta-libs/regexp_1.5.bb
index ce6150c..d482e4a 100644
--- a/recipes-core/jakarta-libs/regexp_1.5.bb
+++ b/recipes-core/jakarta-libs/regexp_1.5.bb
@@ -6,7 +6,7 @@ PR = "r1"
SRC_URI = "http://archive.apache.org/dist/jakarta/regexp/source/jakarta-${BP}.tar.gz"
-inherit java-library
+inherit java-library java-bootstrap-components
S = "${WORKDIR}/jakarta-${BP}"
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index 5893cbc..6480225 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://jamvm.sourceforge.net/"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-DEPENDS = "zlib classpath virtual/javac-native libffi"
+DEPENDS = "zlib classpath libffi"
DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial-native libffi-native"
RDEPENDS_${PN} = "classpath"
@@ -21,7 +21,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \
"
-inherit java autotools update-alternatives pkgconfig
+inherit java autotools update-alternatives pkgconfig java-bootstrap-components
# This uses 32 bit arm, so force the instruction set to arm, not thumb
ARM_INSTRUCTION_SET = "arm"
diff --git a/recipes-core/jcraft/jsch_0.1.40.bb b/recipes-core/jcraft/jsch_0.1.40.bb
index 337a8eb..d22eb0a 100644
--- a/recipes-core/jcraft/jsch_0.1.40.bb
+++ b/recipes-core/jcraft/jsch_0.1.40.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55e3b6a0987ccd0c34530f3df2d206ae"
SRC_URI = "${SOURCEFORGE_MIRROR}/jsch/jsch-${PV}.zip"
-inherit java-library
+inherit java-library java-bootstrap-components
DEPENDS = "jzlib"
DEPENDS_virtclass-native = "jzlib-native"
diff --git a/recipes-core/jcraft/jzlib_1.0.7.bb b/recipes-core/jcraft/jzlib_1.0.7.bb
index b6f3f64..79fc4d4 100644
--- a/recipes-core/jcraft/jzlib_1.0.7.bb
+++ b/recipes-core/jcraft/jzlib_1.0.7.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://www.jcraft.com/jzlib"
SRC_URI = "http://www.jcraft.com/jzlib/jzlib-${PV}.tar.gz"
-inherit java-library
+inherit java-library java-bootstrap-components
do_compile() {
mkdir -p build
diff --git a/recipes-core/jdepend/jdepend_2.9.1.bb b/recipes-core/jdepend/jdepend_2.9.1.bb
index 9f74f44..8f41c00 100644
--- a/recipes-core/jdepend/jdepend_2.9.1.bb
+++ b/recipes-core/jdepend/jdepend_2.9.1.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "http://clarkware.com/software/JDepend.html"
SRC_URI = "http://www.clarkware.com/software/jdepend-${PV}.zip"
-inherit java-library
+inherit java-library java-bootstrap-components
do_compile() {
mkdir -p build
diff --git a/recipes-core/jlex/jlex_1.2.6.bb b/recipes-core/jlex/jlex_1.2.6.bb
index 4dbe63e..9290fa5 100644
--- a/recipes-core/jlex/jlex_1.2.6.bb
+++ b/recipes-core/jlex/jlex_1.2.6.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
RDEPENDS_${PN} = "java2-runtime"
RDEPENDS_${PN}_virtclass-native = ""
-inherit java-library
+inherit java-library java-bootstrap-components
SRC_URI = "http://www.cs.princeton.edu/~appel/modern/java/JLex/Archive/${PV}/Main.java \
file://jlex \
diff --git a/recipes-core/junit/junit4_4.3.1.bb b/recipes-core/junit/junit4_4.3.1.bb
index 1cb8674..8d9dd31 100644
--- a/recipes-core/junit/junit4_4.3.1.bb
+++ b/recipes-core/junit/junit4_4.3.1.bb
@@ -8,9 +8,7 @@ SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar"
S = "${WORKDIR}"
-inherit java-library
-
-DEPENDS = "fastjar-native"
+inherit java-library java-bootstrap-components
do_compile() {
mkdir -p build
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb
index bae022d..54ce9fe 100644
--- a/recipes-core/junit/junit_3.8.2.bb
+++ b/recipes-core/junit/junit_3.8.2.bb
@@ -11,7 +11,7 @@ S = "${WORKDIR}/junit${PV}"
DEPENDS += "unzip-native"
-inherit java-library
+inherit java-library java-bootstrap-components
do_unpackpost() {
mkdir -p src
diff --git a/recipes-core/rhino/rhino_1.7r4.bb b/recipes-core/rhino/rhino_1.7r4.bb
index 7898d23..76c3057 100644
--- a/recipes-core/rhino/rhino_1.7r4.bb
+++ b/recipes-core/rhino/rhino_1.7r4.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e2372bdbf22c99279ae4599a13cc458"
BBCLASSEXTEND = "native"
-inherit java-library
+inherit java-library java-bootstrap-components
SRC_URI = "\
https://github.com/downloads/mozilla/rhino/rhino1_7R4.zip \
diff --git a/recipes-core/servlet-api/servlet2.3_4.1.37.bb b/recipes-core/servlet-api/servlet2.3_4.1.37.bb
index fbda5c8..f5f6d4a 100644
--- a/recipes-core/servlet-api/servlet2.3_4.1.37.bb
+++ b/recipes-core/servlet-api/servlet2.3_4.1.37.bb
@@ -6,12 +6,10 @@ PR = "r1"
SRC_URI = "http://archive.apache.org/dist/tomcat/tomcat-4/v${PV}/src/apache-tomcat-${PV}-src.tar.gz"
-inherit java-library
+inherit java-library java-bootstrap-components
S = "${WORKDIR}/apache-tomcat-${PV}-src/servletapi"
-DEPENDS = "fastjar-native"
-
# Value of implementation.revision in build.xml
IMPL_REVISION = "1"
diff --git a/recipes-core/servlet-api/servlet2.4_5.5.26.bb b/recipes-core/servlet-api/servlet2.4_5.5.26.bb
index b34b23d..7d0feb3 100644
--- a/recipes-core/servlet-api/servlet2.4_5.5.26.bb
+++ b/recipes-core/servlet-api/servlet2.4_5.5.26.bb
@@ -9,8 +9,6 @@ S = "${WORKDIR}/apache-tomcat-${PV}-src/servletapi/jsr154"
inherit java-library
-DEPENDS = "fastjar-native"
-
# Value of implementation.revision in build.xml
IMPL_REVISION = "1"
diff --git a/recipes-core/xalan-j/xalan-j_2.7.1.bb b/recipes-core/xalan-j/xalan-j_2.7.1.bb
index 317b3c9..16f5396 100644
--- a/recipes-core/xalan-j/xalan-j_2.7.1.bb
+++ b/recipes-core/xalan-j/xalan-j_2.7.1.bb
@@ -21,7 +21,7 @@ SRC_URI = "\
S = "${WORKDIR}/${BPN}_2_7_1"
-inherit java-library
+inherit java-library java-bootstrap-components
JPN = "libxalan2-java"
diff --git a/recipes-core/xerces-j/xerces-j_2.11.0.bb b/recipes-core/xerces-j/xerces-j_2.11.0.bb
index f9e497e..4130457 100644
--- a/recipes-core/xerces-j/xerces-j_2.11.0.bb
+++ b/recipes-core/xerces-j/xerces-j_2.11.0.bb
@@ -16,12 +16,12 @@ SRC_URI = "http://archive.apache.org/dist/xerces/j/Xerces-J-src.${PV}.tar.gz"
S = "${WORKDIR}/xerces-2_11_0"
-inherit java-library
+inherit java-library java-bootstrap-components
JPN = "libxerces2-java"
-DEPENDS = "fastjar-native jaxp1.3 xml-commons-resolver1.1"
-DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native xml-commons-resolver1.1-native"
+DEPENDS = "jaxp1.3 xml-commons-resolver1.1"
+DEPENDS_virtclass-native = "jaxp1.3-native xml-commons-resolver1.1-native"
RDEPENDS_${PN} = "libjaxp1.3-java libxml-commons-resolver1.1-java"
RDEPENDS_${PN}_virtclass-native = ""
diff --git a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb
index a6eeb57..765b766 100644
--- a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb
+++ b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb
@@ -11,9 +11,7 @@ LIC_FILES_CHKSUM = " \
SRC_URI = "http://archive.apache.org/dist/xml/commons/source/xml-commons-external-${PV}-src.tar.gz;subdir=${BPN}-${PV}"
-inherit java-library
-
-DEPENDS = "fastjar-native"
+inherit java-library java-bootstrap-components
JARFILENAME = "jaxp-1.3.jar"
ALTJARFILENAMES = "xml-apis.jar"
diff --git a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
index 5853895..ca1f2f2 100644
--- a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
+++ b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.resolver.txt;md5=d229da563da18fe5d58cd95a6467
SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz"
-inherit java-library
+inherit java-library java-bootstrap-components
S = "${WORKDIR}/xml-commons-resolver-${PV}"
-DEPENDS = "fastjar-native jaxp1.3"
-DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native"
+DEPENDS = "jaxp1.3"
+DEPENDS_virtclass-native = "jaxp1.3-native"
do_unpackpost() {
find src -exec \
diff --git a/recipes-core/xml-commons/xpp2_2.1.10.bb b/recipes-core/xml-commons/xpp2_2.1.10.bb
index d3baca4..402d38d 100644
--- a/recipes-core/xml-commons/xpp2_2.1.10.bb
+++ b/recipes-core/xml-commons/xpp2_2.1.10.bb
@@ -9,8 +9,6 @@ S = "${WORKDIR}/PullParser${PV}"
inherit java-library
-DEPENDS = "fastjar-native virtual/javac-native"
-
do_compile() {
if [ -d build-oe ]; then
rm -rf build-oe
diff --git a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
index bedb8a9..a472a0d 100644
--- a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
+++ b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
@@ -8,8 +8,6 @@ SRC_URI = "http://www.extreme.indiana.edu/dist/java-repository/xpp3/distribution
inherit java-library
-DEPENDS = "fastjar-native virtual/javac-native"
-
PACKAGES = "libxpp3-xpath-java ${JPN}"
do_compile() {