aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb3
-rw-r--r--recipes-core/openjdk/patches-openjdk-7/icedtea-jdk-fix-xattr-include.patch11
-rw-r--r--recipes-core/openjdk/patches-openjdk-7/icedtea-m4-fix-xattr-include-path.patch11
3 files changed, 25 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
index 87de6be..d774cc2 100644
--- a/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
+++ b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
@@ -41,6 +41,7 @@ OEPATCHES = "\
file://build-hacks.patch \
file://fix_hotspot_crosscompile.patch \
file://icedtea-makefile-unzip.patch \
+ file://icedtea-m4-fix-xattr-include-path.patch \
"
ICEDTEAPATCHES = "\
@@ -50,6 +51,7 @@ ICEDTEAPATCHES = "\
file://icedtea-crosscompile-fix.patch;apply=no \
file://icedtea-xawt-crosscompile-fix.patch;apply=no \
file://icedtea-jdk-unzip.patch;apply=no \
+ file://icedtea-jdk-fix-xattr-include.patch;apply=no \
file://icedtea-dtrace-std_h.patch;apply=no \
file://icedtea-hotspot-fix-string-literal-marcos.patch;apply=no \
file://icedtea-flags-to-compile-with-GCC-6.patch;apply=no \
@@ -63,6 +65,7 @@ DISTRIBUTION_PATCHES = "\
patches/icedtea-crosscompile-fix.patch \
patches/icedtea-xawt-crosscompile-fix.patch \
patches/icedtea-jdk-unzip.patch \
+ patches/icedtea-jdk-fix-xattr-include.patch \
patches/icedtea-dtrace-std_h.patch \
patches/icedtea-hotspot-fix-string-literal-marcos.patch \
patches/icedtea-flags-to-compile-with-GCC-6.patch \
diff --git a/recipes-core/openjdk/patches-openjdk-7/icedtea-jdk-fix-xattr-include.patch b/recipes-core/openjdk/patches-openjdk-7/icedtea-jdk-fix-xattr-include.patch
new file mode 100644
index 0000000..ef44e7e
--- /dev/null
+++ b/recipes-core/openjdk/patches-openjdk-7/icedtea-jdk-fix-xattr-include.patch
@@ -0,0 +1,11 @@
+--- openjdk/jdk/src/solaris/native/sun/nio/fs/LinuxNativeDispatcher.c
++++ openjdk/jdk/src/solaris/native/sun/nio/fs/LinuxNativeDispatcher.c
+@@ -38,7 +38,7 @@
+
+ #ifdef COMPILE_AGAINST_SYSCALLS
+ #include <sys/types.h>
+-#include <attr/xattr.h>
++#include <sys/xattr.h>
+ #else
+ #include <syscalls_fp.h>
+ #endif
diff --git a/recipes-core/openjdk/patches-openjdk-7/icedtea-m4-fix-xattr-include-path.patch b/recipes-core/openjdk/patches-openjdk-7/icedtea-m4-fix-xattr-include-path.patch
new file mode 100644
index 0000000..f9b526f
--- /dev/null
+++ b/recipes-core/openjdk/patches-openjdk-7/icedtea-m4-fix-xattr-include-path.patch
@@ -0,0 +1,11 @@
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -2234,7 +2234,7 @@
+ dnl Check for syscalls
+ AC_CHECK_FUNCS([openat64 fstatat64 fgetxattr fsetxattr fremovexattr flistxattr unlinkat renameat futimesat fdopendir epoll_create epoll_ctl epoll_wait],,
+ [AC_MSG_ERROR([Could not find required syscalls; check config.log and use --disable-compile-against-syscalls if necessary.])])
+- AC_CHECK_HEADERS([sys/epoll.h attr/xattr.h],
++ AC_CHECK_HEADERS([sys/epoll.h sys/xattr.h],
+ , [AC_MSG_ERROR([Could not find required system headers; install the appropriate files from glibc-headers, libc6-dev and/or libattr-devel, libattr1-dev or use --disable-compile-against-syscalls if necessary.])])
+ ENABLE_SYSCALL_COMPILATION=true
+ fi