aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README4
-rw-r--r--classes/java-library.bbclass8
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend13
-rw-r--r--recipes-core/libmatthew/libmatthew.inc2
-rw-r--r--recipes-core/openjdk/openjdk-8-release-172b11-common.inc5
-rw-r--r--recipes-extended/rxtx/rxtx_2.2.0.bb2
6 files changed, 15 insertions, 19 deletions
diff --git a/README b/README
index 031709e..7906324 100644
--- a/README
+++ b/README
@@ -63,8 +63,8 @@ Testing
The meta-java layer may be tested using oeqa's runtime image tests. The easiest
way is to add the following configuration to your local.conf:
-SANITY_TESTED_DISTROS=""
-TEST_IMAGE = "1"
+SANITY_TESTED_DISTROS = ""
+TESTIMAGE_AUTO = "1"
Then you should be able to use the open{jre,jdk}-{7,8}-test-image recipes.
Furthermore you could also include the tests provided in lib/oeqa/runtime/cases
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass
index ce1cd28..e0159ba 100644
--- a/classes/java-library.bbclass
+++ b/classes/java-library.bbclass
@@ -10,9 +10,13 @@
#
# package archs are set to all, if the recipe builds also packages which
# can not be used for all archs, then set the PACKAGE_ARCH of that package
-# manually, see rxtx_xx.bb for an example.
+# manually *before* inheriting the class, see rxtx_xx.bb for an example.
-inherit java allarch
+inherit java
+PACKAGE_ARCH ?= "all"
+# Fully expanded - so it applies the overrides as well
+PACKAGE_ARCH_EXPANDED := "${PACKAGE_ARCH}"
+inherit ${@oe.utils.ifelse(d.getVar('PACKAGE_ARCH_EXPANDED') == 'all', 'allarch', '')}
# use java_stage for native packages
JAVA_NATIVE_STAGE_INSTALL = "1"
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
deleted file mode 100644
index 4651185..0000000
--- a/recipes-core/base-files/base-files_3.0.14.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
-do_install_append() {
- cat >> ${D}${sysconfdir}/profile << EOT
-JAVA_HOME=""
-for dir in ${libdir}/jvm/*; do
- if [ -x "\${dir}/bin/java" ]; then
- [ -z "\${JAVA_HOME}" ] && JAVA_HOME="\${dir}"
- fi
-done
-if [ -n "\${JAVA_HOME}" ]; then
- export JAVA_HOME=\${JAVA_HOME}
-fi
-EOT
-}
diff --git a/recipes-core/libmatthew/libmatthew.inc b/recipes-core/libmatthew/libmatthew.inc
index 7db979b..2119c0b 100644
--- a/recipes-core/libmatthew/libmatthew.inc
+++ b/recipes-core/libmatthew/libmatthew.inc
@@ -7,8 +7,8 @@ DEPENDS = "virtual/java-native classpath-native classpath"
S = "${WORKDIR}/libmatthew-java-${PV}"
-inherit java-library
PACKAGE_ARCH = "${TUNE_PKGARCH}"
+inherit java-library
# Some internal version numbers which change from time to time.
# Allowing to override them makes this include file more
diff --git a/recipes-core/openjdk/openjdk-8-release-172b11-common.inc b/recipes-core/openjdk/openjdk-8-release-172b11-common.inc
index ad20585..f3bbf0a 100644
--- a/recipes-core/openjdk/openjdk-8-release-172b11-common.inc
+++ b/recipes-core/openjdk/openjdk-8-release-172b11-common.inc
@@ -94,6 +94,11 @@ ARM_INSTRUCTION_SET_armv4t = "ARM"
BUILD_CFLAGS_append = " -Wno-error=deprecated-declarations"
TARGET_CFLAGS_append = " -Wno-error=deprecated-declarations"
+# WORKAROUND: disable the "specified bound depends on the length of the source argument"
+# compiler error until we update openjdk8 to a fixed version
+BUILD_CFLAGS_append = " -Wno-error=stringop-overflow"
+TARGET_CFLAGS_append = " -Wno-error=stringop-overflow"
+
# Enable zero mode for arm based builds, as normal hotspot fails to build
PACKAGECONFIG_append_armv4 = " zero"
PACKAGECONFIG_append_armv5 = " zero"
diff --git a/recipes-extended/rxtx/rxtx_2.2.0.bb b/recipes-extended/rxtx/rxtx_2.2.0.bb
index e54dad7..d4fbb9d 100644
--- a/recipes-extended/rxtx/rxtx_2.2.0.bb
+++ b/recipes-extended/rxtx/rxtx_2.2.0.bb
@@ -28,8 +28,8 @@ S = "${WORKDIR}/rxtx-2.2pre2"
INSANE_SKIP_${JPN} += "dev-so"
-inherit autotools-brokensep java-library remove-libtool
PACKAGE_ARCH = "${TUNE_PKGARCH}"
+inherit autotools-brokensep java-library remove-libtool
JARFILENAME = "RXTXcomm.jar"
EXTRA_OEMAKE += "RXTX_PATH=${D}${libdir_jni} \