aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/xml-commons/jdom_1.1.3.bb25
-rw-r--r--recipes-core/xml-commons/jdom_1.1.bb28
2 files changed, 25 insertions, 28 deletions
diff --git a/recipes-core/xml-commons/jdom_1.1.3.bb b/recipes-core/xml-commons/jdom_1.1.3.bb
new file mode 100644
index 0000000..8997bcc
--- /dev/null
+++ b/recipes-core/xml-commons/jdom_1.1.3.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Parses, manipulates, and outputs XML using standard Java constructs"
+DESCRIPTION = "JDOM aims to provide a complete, Java-based solution for \
+accessing, manipulating, and outputting XML data from Java code."
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=897c700e4c122d8f4ef8f6d253a6f744"
+
+HOMEPAGE = "http://jdom.org/"
+
+DEPENDS = "fastjar-native virtual/javac-native jaxen"
+
+SRC_URI = "http://www.jdom.org/dist/source/archive/jdom-${PV}.tar.gz"
+SRC_URI[md5sum] = "dc8391e84cfdb170fcd8279aa370019f"
+SRC_URI[sha256sum] = "d471718c4ac7a1a2f10715b93cb3fcd2ecbab60384b73ad1c089712e47bd8d1f"
+
+inherit java-library
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s jaxen
+
+ javac -sourcepath src/java -cp $cp -d build `find src/java -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
diff --git a/recipes-core/xml-commons/jdom_1.1.bb b/recipes-core/xml-commons/jdom_1.1.bb
deleted file mode 100644
index 4867e82..0000000
--- a/recipes-core/xml-commons/jdom_1.1.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-DESCRIPTION = "Parses, manipulates, and outputs XML using standard Java constructs"
-LICENSE = "BSD"
-
-HOMEPAGE = "http://jdom.org/"
-
-DEPENDS = "fastjar-native jaxen"
-
-SRC_URI = "\
- http://www.jdom.org/dist/binary/archive/jdom-${PV}.tar.gz \
- "
-
-PNBLACKLIST[jdom] ?= "BROKEN: indirectly depends on broken 'xom'"
-
-inherit java-library
-
-do_compile() {
- mkdir -p build
-
- oe_makeclasspath cp -s jaxen
-
- javac -sourcepath src/java -cp $cp -d build `find src/java -name "*.java"`
-
- fastjar -C build -c -f ${JARFILENAME} .
-}
-
-
-SRC_URI[md5sum] = "22745cbaaddb12884ed8ee09083d8fe2"
-SRC_URI[sha256sum] = "a13549087141be24ad176b659afdc2c675f1ffa5288ff999a193d6d44a282056"