aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch20
-rw-r--r--recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch10
-rw-r--r--recipes-core/jamvm/jamvm/libffi.patch38
3 files changed, 47 insertions, 21 deletions
diff --git a/recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch b/recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch
index f0884fd..f76da3c 100644
--- a/recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch
+++ b/recipes-core/jamvm/jamvm/jamvm-jni_h-noinst.patch
@@ -1,9 +1,17 @@
-Index: jamvm-1.5.3/src/Makefile.am
-===================================================================
---- jamvm-1.5.3.orig/src/Makefile.am 2009-09-29 09:29:13.386565473 +0200
-+++ jamvm-1.5.3/src/Makefile.am 2009-09-29 09:33:47.702565852 +0200
-@@ -23,7 +23,7 @@
- DIST_SUBDIRS = os arch interp
+From a0169a5569a0373558bd99143a02ba3ebe80b81b Mon Sep 17 00:00:00 2001
+From: Henning Heinold <heinold@inf.fu-berlin.de>
+Date: Sat, 12 Nov 2011 20:58:34 +0100
+
+---
+ src/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 1cf2e87..1f06fed 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -23,7 +23,7 @@ SUBDIRS = os interp classlib
+ DIST_SUBDIRS = os arch interp classlib
bin_PROGRAMS = jamvm
-include_HEADERS = jni.h
diff --git a/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch b/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch
index bf0fda5..44fa606 100644
--- a/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch
+++ b/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch
@@ -1,5 +1,13 @@
+From 2409bdf5de64f1a6f2d8d3c738b06d394b47c198 Mon Sep 17 00:00:00 2001
+From: Jan Luebbe <jlu@pengutronix.de>
+Date: Tue, 15 May 2012 09:56:31 +0000
+
+---
+ src/jam.c | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
diff --git a/src/jam.c b/src/jam.c
-index b76ce8b..dc5eac3 100644
+index 052f84a..460e4d3 100644
--- a/src/jam.c
+++ b/src/jam.c
@@ -133,9 +133,7 @@ int parseCommandLine(int argc, char *argv[], InitArgs *args) {
diff --git a/recipes-core/jamvm/jamvm/libffi.patch b/recipes-core/jamvm/jamvm/libffi.patch
index 1f68c5e..36143d7 100644
--- a/recipes-core/jamvm/jamvm/libffi.patch
+++ b/recipes-core/jamvm/jamvm/libffi.patch
@@ -1,8 +1,17 @@
-Index: git/configure.ac
-===================================================================
---- git.orig/configure.ac 2011-11-18 15:47:15.339088111 +0100
-+++ git/configure.ac 2011-11-18 15:47:15.742392674 +0100
-@@ -273,9 +273,24 @@
+From fcd374ce67c0385ca94b09dfc1b1ddf13c3f631a Mon Sep 17 00:00:00 2001
+From: Henning Heinold <heinold@inf.fu-berlin.de>
+Date: Sat, 12 Nov 2011 20:58:34 +0100
+
+---
+ configure.ac | 27 ++++++++++++++++++++-------
+ src/Makefile.am | 5 +++--
+ 2 files changed, 23 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 138b7e6..cc1990a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -272,9 +272,24 @@ if test "$enable_zip" != no; then
AC_CHECK_LIB(z,inflate,,AC_MSG_ERROR(zlib is missing))
fi
@@ -29,7 +38,7 @@ Index: git/configure.ac
dnl Checks for header files.
AC_HEADER_STDC
-@@ -285,10 +300,6 @@
+@@ -284,10 +299,6 @@ if test "$enable_zip" != no; then
AC_CHECK_HEADER(zlib.h,,AC_MSG_ERROR(zlib.h is missing))
fi
@@ -40,7 +49,7 @@ Index: git/configure.ac
if test "$enable_zip" != no; then
AC_DEFINE([USE_ZIP],1,[use zip])
use_zip_yes=
-@@ -302,7 +313,9 @@
+@@ -301,7 +312,9 @@ AC_SUBST(use_zip_yes)
AC_SUBST(use_zip_no)
if test "$enable_ffi" != no; then
@@ -51,13 +60,13 @@ Index: git/configure.ac
fi
if test "$enable_md_stubs" != no; then
-Index: git/src/Makefile.am
-===================================================================
---- git.orig/src/Makefile.am 2011-11-18 15:47:15.685730049 +0100
-+++ git/src/Makefile.am 2011-11-18 15:49:43.881825251 +0100
-@@ -43,8 +43,9 @@
- jamvm_LDADD = libcore.la
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 1f06fed..9c39edb 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -44,9 +44,10 @@ jamvm_LDADD = libcore.la
libjvm_la_LIBADD = libcore.la
+ libjvm_la_LDFLAGS = -avoid-version
libcore_la_LIBADD = interp/libinterp.la os/@os@/@arch@/libnative.la \
- os/@os@/libos.la classlib/@classlib@/libclasslib.la
+ os/@os@/libos.la classlib/@classlib@/libclasslib.la \
@@ -66,4 +75,5 @@ Index: git/src/Makefile.am
-AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine
+AM_CPPFLAGS = -I$(top_srcdir)/src/interp/engine $(LIBFFI_CFLAGS)
- DISTCLEANFILES = arch.h classlib.h classlib-defs.h classlib-symbol.h
+ DISTCLEANFILES = arch.h classlib.h classlib-defs.h classlib-symbol.h \
+ classlib-excep.h