aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/openjdk/openjdk-8-cross.inc14
-rw-r--r--recipes-core/openjdk/openjdk-8_102b14.bb14
-rw-r--r--recipes-core/openjdk/openjre-8_102b14.bb14
3 files changed, 14 insertions, 28 deletions
diff --git a/recipes-core/openjdk/openjdk-8-cross.inc b/recipes-core/openjdk/openjdk-8-cross.inc
index 3973fcf..247438f 100644
--- a/recipes-core/openjdk/openjdk-8-cross.inc
+++ b/recipes-core/openjdk/openjdk-8-cross.inc
@@ -1,6 +1,20 @@
JDK_HOME = "${libdir_jvm}/openjdk-8"
JRE_HOME = "${libdir_jvm}/openjre-8"
+# some patches extracted from http://cr.openjdk.java.net/~rkennke/shark-build-hotspot/webrev.01/hotspot.patch
+# reported via http://mail.openjdk.java.net/pipermail/build-dev/2015-January/013972.html
+# by Roman Kennke (rkennke at redhat.com)
+PATCHES_URI_append = "\
+ file://openjdk8-restrict-to-staging-dir.patch;apply=no \
+ file://openjdk8-fix-shark-build.patch;apply=no \
+ file://openjdk8-fix-shark-stdc++11.patch;apply=no \
+ file://openjdk8-fix-assembler-flag-handling-in-makefile.patch;apply=no \
+ file://openjdk8-fix-adlc-flags.patch;apply=no \
+ file://openjdk8-silence-d_fortify_source-warning.patch;apply=no \
+ file://openjdk8-fix-zero-mode-crash.patch;apply=no \
+ file://openjdk8-add-missing-linker-flags.patch;apply=no \
+"
+
DEPENDS = "\
openjdk-8-native zip-native ant-native libxslt \
jpeg libpng krb5 libffi fontconfig freetype \
diff --git a/recipes-core/openjdk/openjdk-8_102b14.bb b/recipes-core/openjdk/openjdk-8_102b14.bb
index 210c897..efed329 100644
--- a/recipes-core/openjdk/openjdk-8_102b14.bb
+++ b/recipes-core/openjdk/openjdk-8_102b14.bb
@@ -1,20 +1,6 @@
require openjdk-8-release-102b14.inc
require openjdk-8-cross.inc
-# some patches extracted from http://cr.openjdk.java.net/~rkennke/shark-build-hotspot/webrev.01/hotspot.patch
-# reported via http://mail.openjdk.java.net/pipermail/build-dev/2015-January/013972.html
-# by Roman Kennke (rkennke at redhat.com)
-PATCHES_URI_append = "\
- file://openjdk8-restrict-to-staging-dir.patch;apply=no \
- file://openjdk8-fix-shark-build.patch;apply=no \
- file://openjdk8-fix-shark-stdc++11.patch;apply=no \
- file://openjdk8-fix-assembler-flag-handling-in-makefile.patch;apply=no \
- file://openjdk8-fix-adlc-flags.patch;apply=no \
- file://openjdk8-silence-d_fortify_source-warning.patch;apply=no \
- file://openjdk8-fix-zero-mode-crash.patch;apply=no \
- file://openjdk8-add-missing-linker-flags.patch;apply=no \
-"
-
do_install() {
rm -rf ${D}${JDK_HOME}
mkdir -p ${D}${JDK_HOME}
diff --git a/recipes-core/openjdk/openjre-8_102b14.bb b/recipes-core/openjdk/openjre-8_102b14.bb
index 88160e1..f47c62c 100644
--- a/recipes-core/openjdk/openjre-8_102b14.bb
+++ b/recipes-core/openjdk/openjre-8_102b14.bb
@@ -1,20 +1,6 @@
require openjdk-8-release-102b14.inc
require openjdk-8-cross.inc
-# some patches extracted from http://cr.openjdk.java.net/~rkennke/shark-build-hotspot/webrev.01/hotspot.patch
-# reported via http://mail.openjdk.java.net/pipermail/build-dev/2015-January/013972.html
-# by Roman Kennke (rkennke at redhat.com)
-PATCHES_URI_append = "\
- file://openjdk8-restrict-to-staging-dir.patch;apply=no \
- file://openjdk8-fix-shark-build.patch;apply=no \
- file://openjdk8-fix-shark-stdc++11.patch;apply=no \
- file://openjdk8-fix-assembler-flag-handling-in-makefile.patch;apply=no \
- file://openjdk8-fix-adlc-flags.patch;apply=no \
- file://openjdk8-silence-d_fortify_source-warning.patch;apply=no \
- file://openjdk8-fix-zero-mode-crash.patch;apply=no \
- file://openjdk8-add-missing-linker-flags.patch;apply=no \
-"
-
do_install() {
rm -rf ${D}${JRE_HOME}
mkdir -p ${D}${JRE_HOME}