aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/icedtea/icedtea7-native.inc10
-rw-r--r--recipes-core/jamvm/jamvm-initial_1.4.5.bb2
-rw-r--r--recipes-core/jamvm/jamvm.inc2
3 files changed, 7 insertions, 7 deletions
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc
index b9e2056..aa105b7 100644
--- a/recipes-core/icedtea/icedtea7-native.inc
+++ b/recipes-core/icedtea/icedtea7-native.inc
@@ -35,6 +35,8 @@ B = "${S}/build"
# openjdk looks in /usr/include and /usr/lib for freetype by default.
export ALT_FREETYPE_HEADERS_PATH = "${STAGING_INCDIR}/freetype2"
export ALT_FREETYPE_LIB_PATH = "${STAGING_LIBDIR}"
+export LD_LIBRARY_PATH = "$LD_LIBRARY_PATH:${STAGING_LIBDIR}/classpath:${STAGING_LIBDIR}/jamvm"
+export BOOTCLASSPATH = "${STAGING_DATADIR}/jamvm/classes.zip:${STAGING_DATADIR}/classpath/glibj.zip"
# OpenJDK supports parallel compilation but uses a plain number for this.
# In OE we have PARALLEL_MAKE which is the actual option passed to make,
@@ -55,10 +57,8 @@ def get_jdk7_native_jobs(d):
# Whatever found in PARALLEL_MAKE was not suitable.
return "1"
-JDK_JOBS = "${@get_jdk7_native_jobs(d)}"
-
EXTRA_OECONF = "\
- --with-parallel-jobs=${JDK_JOBS} \
+ --with-parallel-jobs=${@get_jdk7_native_jobs(d)} \
\
--disable-tests \
--disable-hotspot-tests \
@@ -88,8 +88,6 @@ JDK_DIR = "icedtea7-native"
JDK_INSTALL_DIR = "${D}/${libdir_jvm}/${JDK_DIR}"
do_configure_prepend() {
- echo "Configure with parallel-jobs: ${JDK_JOBS}"
-
case "${TRANSLATED_TARGET_ARCH}" in
x86-64)
libarch=amd64
@@ -248,3 +246,5 @@ do_install() {
# Fix missing write permissions on the files.
chmod ug+w -R ${JDK_INSTALL_DIR}
}
+
+get_jdk7_native_jobs[vardepsexclude] += "ICEDTEA_PARALLEL_MAKE"
diff --git a/recipes-core/jamvm/jamvm-initial_1.4.5.bb b/recipes-core/jamvm/jamvm-initial_1.4.5.bb
index d317695..4c64f6a 100644
--- a/recipes-core/jamvm/jamvm-initial_1.4.5.bb
+++ b/recipes-core/jamvm/jamvm-initial_1.4.5.bb
@@ -47,4 +47,4 @@ SRC_URI[md5sum] = "3f538bab6e1c77aed331e5e71f754f5b"
SRC_URI[sha256sum] = "f329d1c8f42c06b53a3e82763d33900b100b8e9acd7afe02f7583c51253fd6e5"
# shared state for jamvm-native does not work
# since the paths are hardcoded
-SSTATE_MIRRORS_class-native = ""
+#SSTATE_MIRRORS_class-native = ""
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index ee0e5c0..84c8513 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -49,5 +49,5 @@ ALTERNATIVE_PATH = "${bindir}/jamvm"
ALTERNATIVE_PRIORITY = "4"
# shared state for jamvm-native does not work
# since the paths are hardcoded
-SSTATE_MIRRORS_class-native = ""
+#SSTATE_MIRRORS_class-native = ""