aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/jamvm/jamvm/annotations.patch31
-rw-r--r--recipes-core/jamvm/jamvm_git.bb6
2 files changed, 34 insertions, 3 deletions
diff --git a/recipes-core/jamvm/jamvm/annotations.patch b/recipes-core/jamvm/jamvm/annotations.patch
new file mode 100644
index 0000000..6279366
--- /dev/null
+++ b/recipes-core/jamvm/jamvm/annotations.patch
@@ -0,0 +1,31 @@
+Index: git/src/classlib/gnuclasspath/annotations.c
+===================================================================
+--- git.orig/src/classlib/gnuclasspath/annotations.c 2013-07-29 10:44:38.597241346 +0000
++++ git/src/classlib/gnuclasspath/annotations.c 2013-07-29 11:03:42.927744962 +0000
+@@ -247,7 +247,7 @@
+ return anno;
+ }
+
+-Object *parseAnnotations(Class *class, AnnotationData *annotations) {
++Object *parseAnnotations(Class *class, AttributeData *annotations) {
+ if(!anno_inited && !initAnnotation())
+ return NULL;
+
+@@ -290,7 +290,7 @@
+ }
+
+ Object *getMethodParameterAnnotations(MethodBlock *mb) {
+- AnnotationData *annotations;
++ AttributeData *annotations;
+ Object **outer_array_data;
+ Object *outer_array;
+ int no_params, i;
+@@ -342,7 +342,7 @@
+ }
+
+ Object *getMethodDefaultValue(MethodBlock *mb) {
+- AnnotationData *annotations;
++ AttributeData *annotations;
+
+ if(!anno_inited && !initAnnotation())
+ return NULL;
diff --git a/recipes-core/jamvm/jamvm_git.bb b/recipes-core/jamvm/jamvm_git.bb
index 88df6fc..97ed1cc 100644
--- a/recipes-core/jamvm/jamvm_git.bb
+++ b/recipes-core/jamvm/jamvm_git.bb
@@ -3,15 +3,15 @@
require jamvm.inc
-SRCREV = "0972452d441544f7dd29c55d64f1ce3a5db90d82"
+SRCREV = "ac22c9948434e528ece451642b4ebde40953ee7e"
PV = "1.5.5+1.6.0-devel+git${SRCPV}"
-PR = "r4"
-
SRC_URI = "git://git.berlios.de/jamvm;protocol=git \
file://jamvm-jni_h-noinst.patch \
file://libffi.patch \
file://jamvm-minmax-heap.patch \
+ file://annotations.patch \
+ file://java \
"
S = "${WORKDIR}/git"