aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-yocto-ivi/images/cassini-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-yocto-ivi/images/cassini-image.bb')
-rw-r--r--recipes-yocto-ivi/images/cassini-image.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-yocto-ivi/images/cassini-image.bb b/recipes-yocto-ivi/images/cassini-image.bb
new file mode 100644
index 0000000..219c0fd
--- /dev/null
+++ b/recipes-yocto-ivi/images/cassini-image.bb
@@ -0,0 +1,20 @@
+IMAGE_INSTALL = "task-core-boot-genivi ${ROOTFS_PKGMANAGE_BOOTSTRAP} ${CORE_IMAGE_EXTRA_INSTALL} task-core-p1 task-core-p2"
+
+EXTRA_IMAGE_FEATURES = "debug-tweaks"
+EXTRA_IMAGEDEPENDS += "qemu-native qemu-helper-native"
+
+IMAGE_LINGUAS = " "
+
+LICENSE = "MIT"
+
+# Check if image should be created
+IMAGE_SD = '${@base_contains("IMAGE_FSTYPES", "sdimg", "sd", "core", d)}'
+inherit ${IMAGE_SD}-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+# remove not needed ipkg informations
+ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "
+
+# Create SD image symlink currectly
+IMAGE_POSTPROCESS_COMMAND_imx53qsb += "rename_symlink ; "