aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
new file mode 100644
index 0000000..76f3324
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
@@ -0,0 +1,23 @@
+PRINC = "2"
+
+LIB_DEPS += "virtual/libgl"
+
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
+inherit systemd
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE = "X.service"
+
+SRC_URI_append = " file://X.service \
+ "
+
+# If we don't have mesa-dri as virtual/gl we deactivate this support in xserver and
+# remove remove xorg-extension-glx from RDEPENDS as we use OPENGLES and EGL
+python () {
+ if ((d.getVar("PREFERRED_PROVIDER_virtual/libgl", True) or "").find("mesa-dri") == -1):
+ extraoeconf = d.getVar("EXTRA_OECONF", True)
+ extraoeconf += " --disable-glx --disable-dri"
+ d.setVar('EXTRA_OECONF', extraoeconf)
+ else:
+ d.setVar('RDEPENDS_xserver-xorg', "xserver-xorg-extension-glx")
+}