aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/node-startup-controller/node-startup-controller_1.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/node-startup-controller/node-startup-controller_1.0.2.bb')
-rw-r--r--recipes-extended/node-startup-controller/node-startup-controller_1.0.2.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes-extended/node-startup-controller/node-startup-controller_1.0.2.bb b/recipes-extended/node-startup-controller/node-startup-controller_1.0.2.bb
new file mode 100644
index 0000000..1042d40
--- /dev/null
+++ b/recipes-extended/node-startup-controller/node-startup-controller_1.0.2.bb
@@ -0,0 +1,54 @@
+DEFAULT_PREFERRENCE = "-1"
+
+SUMMARY = "GENIVI Node Startup Controller"
+DESCRIPTION = "The GENIVI Node Startup Controller \
+ - manages the Last User Context (LUC) \
+ - monitors node startup \
+ and \
+ - manages legacy applications within a node \
+ "
+
+HOMEPAGE = "https://www.genivi.org/"
+SECTION = "base"
+
+LICENSE = "MPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=815ca599c9df247a0c7f619bab123dad"
+
+# tag 1.0.2 : 717e743c84ef9c168501dcbc012c4212f1903581
+SRC_URI = "git://git.projects.genivi.org/lifecycle/node-startup-controller.git;protocol=git;tag=717e743c84ef9c168501dcbc012c4212f1903581 \
+ file://use-systemd-unit-dir.patch"
+PR = "r0"
+
+DEPENDS = "glib-2.0 dlt-daemon systemd"
+
+S = "${WORKDIR}/git"
+
+inherit autotools gtk-doc systemd
+do_configure_prepend () {
+ mkdir m4
+}
+
+PACKAGES =+ "${PN}-nsm-dummy ${PN}-nsm-dummy-dbg"
+
+SYSTEMD_PACKAGES = "${PN}-systemd ${PN}-nsm-dummy-systemd"
+SYSTEMD_SERVICE_${PN}-systemd = "node-startup-controller.service"
+SYSTEMD_SERVICE_${PN}-nsm-dummy-systemd = "nsm-dummy.service"
+SYSTEMD_AUTO_ENABLE = "disable"
+
+RRECOMMENDS_${PN} += "${PN}-nsm-dummy"
+
+FILES_${PN} += "\
+ ${libdir}/${PN}-1/${PN} \
+ ${libdir}/${PN}-1/legacy-app-handler \
+ ${datadir}/dbus-1/system-services/org.genivi.NodeStartupController1.service \
+ "
+FILES_${PN}-dbg += "\
+ ${libdir}/${PN}-1/.debug/*ler \
+ "
+FILES_${PN}-nsm-dummy = "\
+ ${libdir}/${PN}-1/nsm-dummy \
+ ${datadir}/dbus-1/system-services/org.genivi.NodeStateManager.* \
+ "
+FILES_${PN}-nsm-dummy-dbg = "\
+ ${libdir}/${PN}-1/.debug/nsm-dummy \
+ "