aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb')
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb
new file mode 100644
index 0000000..c098b09
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-specific-component-p2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "GENIVI P2 Specific components (SC)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+# Avoid hardcoding the full layer path into the checksums
+LIC_FILES_CHKSUM[vardepsexclude] += "IVI_COREBASE"
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-specific-component-p2 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+RDEPENDS_${PN} += "\
+ common-api-c++-dbus \
+ fuse \
+ pulseaudio-server \
+ quota \
+ sqlite3 \
+ wireless-tools \
+ "
+