aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb')
-rw-r--r--meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb
new file mode 100644
index 0000000..3a7abb0
--- /dev/null
+++ b/meta-ivi/recipes-yocto-ivi/packagegroups/packagegroup-abstract-component-p2.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "GENIVI P2 Abstract components (AC)"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${IVI_COREBASE}/meta-ivi/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+# Avoid hardcoding the full layer path into the checksums
+LIC_FILES_CHKSUM[vardepsexclude] += "IVI_COREBASE"
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-abstract-component-p2 \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+
+RDEPENDS_${PN} += "\
+ node-health-monitor \
+ persistence-client-library \
+ "