aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.11.1.bb')
-rw-r--r--meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.11.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.11.1.bb b/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.11.1.bb
new file mode 100644
index 0000000..b97493f
--- /dev/null
+++ b/meta-ivi/recipes-graphics/wayland/wayland-ivi-extension_1.11.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Wayland IVI Extension"
+DESCRIPTION = "GENIVI Layer Management API based on Wayland IVI Extension"
+HOMEPAGE = "http://projects.genivi.org/wayland-ivi-extension"
+BUGTRACKER = "http://bugs.genivi.org/enter_bug.cgi?product=Wayland%20IVI%20Extension"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1f1a56bb2dadf5f2be8eb342acf4ed79"
+
+PR = "r0"
+
+SRCREV = "8fdae4cff2647d0060174509990cd2874e1d793d"
+SRC_URI = "git://github.com/GENIVI/${BPN}.git;protocol=http;branch=1.11 \
+ "
+S = "${WORKDIR}/git"
+
+DEPENDS = "weston"
+
+inherit cmake
+
+EXTRA_OECMAKE := "-DWITH_ILM_INPUT=1"
+
+FILES_${PN} += "${libdir}/weston/*"
+FILES_${PN}-dbg += "${libdir}/weston/.debug/*"
+INSANE_SKIP_${PN} = "dev-deps"
+
+EXTRA_OECMAKE += "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"