aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-extended/common-api/common-api-c++_3.1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-extended/common-api/common-api-c++_3.1.12.bb')
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++_3.1.12.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++_3.1.12.bb b/meta-ivi/recipes-extended/common-api/common-api-c++_3.1.12.bb
new file mode 100644
index 0000000..2abc7f6
--- /dev/null
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++_3.1.12.bb
@@ -0,0 +1,23 @@
+SUMMARY = "CommonAPI"
+SECTION = "libs"
+LICENSE = "MPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
+
+PROVIDES = "commonapi3"
+PR = "r0"
+
+DEPENDS = "dlt-daemon"
+
+inherit cmake lib_package pkgconfig
+
+SRCREV = "008f6c11f5371e93c06b3ed337326008d2031084"
+SRC_URI = "git://github.com/GENIVI/capicxx-core-runtime.git;protocol=https \
+ "
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE += "-DCMAKE_INSTALL_PREFIX=/usr \
+ -DINSTALL_LIB_DIR:PATH=${baselib} \
+ -DINSTALL_CMAKE_DIR:PATH=${baselib}/cmake/CommonAPI \
+ "
+
+FILES_${PN}-dev += "${libdir}/cmake"