summaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch')
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch b/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch
new file mode 100644
index 0000000..1c5eaab
--- /dev/null
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++/fix-with-automake-1-15.patch
@@ -0,0 +1,28 @@
+Call of AC_CONFIG_AUX_DIR should be made as soon as possible to avoid
+issues with automake 1.15.
+
+https://lists.gnu.org/archive/html/bug-automake/2015-01/txttwTAlDA4OE.txt
+https://bugzilla.redhat.com/show_bug.cgi?id=1179182
+
+Signed-off-by: Andrei Gherzan <andrei.gherzan@windriver.com>
+Upstream-Status: Submitted [http://bugs.genivi.org/show_bug.cgi?id=352]
+
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac
++++ git/configure.ac
+@@ -4,10 +4,12 @@ AC_INIT([GENIVI IPC Common API C++],
+ [],
+ [CommonAPI])
+
+-AC_CONFIG_MACRO_DIR([m4])
+-m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
+ AC_CONFIG_AUX_DIR([build-aux])
+ AC_CONFIG_HEADERS([build-aux/config.h])
++
++AC_CONFIG_MACRO_DIR([m4])
++m4_ifdef([AM_PROG_AR], [AM_PROG_AR])
++
+ AC_CONFIG_FILES([
+ Makefile
+ CommonAPI.pc