aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/0001-common-api-dbus-runtime-replace-hard-coded-lib-dir-b.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-extended/common-api/common-api-c++-dbus/0001-common-api-dbus-runtime-replace-hard-coded-lib-dir-b.patch')
-rw-r--r--meta-ivi/recipes-extended/common-api/common-api-c++-dbus/0001-common-api-dbus-runtime-replace-hard-coded-lib-dir-b.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/0001-common-api-dbus-runtime-replace-hard-coded-lib-dir-b.patch b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/0001-common-api-dbus-runtime-replace-hard-coded-lib-dir-b.patch
new file mode 100644
index 0000000..e0b64a5
--- /dev/null
+++ b/meta-ivi/recipes-extended/common-api/common-api-c++-dbus/0001-common-api-dbus-runtime-replace-hard-coded-lib-dir-b.patch
@@ -0,0 +1,36 @@
+From 174781bad5f910f30dfc4adcd6de3c49e1d99988 Mon Sep 17 00:00:00 2001
+From: Clement Dransart <clement.dransart@awtce.be>
+Date: Wed, 15 Jun 2016 11:13:22 +0200
+Subject: [common-api-dbus-runtime][PATCH] replace hard-coded lib dir by
+ variable INSTALL_LIB_DIR
+
+Signed-off-by: Clement Dransart <clement.dransart@awtce.be>
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2750c4e..d651494 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -63,7 +63,7 @@ set(INSTALL_INCLUDE_DIR include/CommonAPI-${COMMONAPI_API_HEADER_VERSION} CACHE
+ if(WIN32 AND NOT CYGWIN)
+ set(DEF_INSTALL_CMAKE_DIR cmake)
+ else()
+- set(DEF_INSTALL_CMAKE_DIR lib/cmake/CommonAPI-DBus-${COMPONENT_VERSION})
++ set(DEF_INSTALL_CMAKE_DIR ${INSTALL_LIB_DIR}/cmake/CommonAPI-DBus-${COMPONENT_VERSION})
+ endif()
+ set(INSTALL_CMAKE_DIR ${DEF_INSTALL_CMAKE_DIR} CACHE PATH "Installation directory for CMake files")
+
+@@ -296,7 +296,7 @@ endif()
+ # create pkg-config file
+ if(NOT WIN32 AND PKG_CONFIG_FOUND)
+ configure_file(CommonAPI-DBus.pc.in ${PROJECT_BINARY_DIR}/CommonAPI-DBus.pc @ONLY)
+- install(FILES ${PROJECT_BINARY_DIR}/CommonAPI-DBus.pc DESTINATION lib/pkgconfig)
++ install(FILES ${PROJECT_BINARY_DIR}/CommonAPI-DBus.pc DESTINATION ${INSTALL_LIB_DIR}/pkgconfig)
+ endif()
+
+ ##############################################################################
+--
+1.9.1
+