aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch')
-rw-r--r--meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch b/meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch
index 9affbbe..08a8651 100644
--- a/meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch
+++ b/meta-ivi/recipes-connectivity/bluez5/bluez5/0001-plugins-Add-initial-code-for-service-plugin.patch
@@ -1,4 +1,4 @@
-From 5b444f8930a2635d52a676f0600e80828cc876c9 Mon Sep 17 00:00:00 2001
+From 44c5dc231eb4ad036356d717c9948701227a673f Mon Sep 17 00:00:00 2001
From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
Date: Sun, 5 Jan 2014 18:02:56 +0200
Subject: [PATCH 01/12] plugins: Add initial code for service plugin
@@ -12,10 +12,10 @@ This plugin will be used to control services individually.
create mode 100644 plugins/service.c
diff --git a/Makefile.plugins b/Makefile.plugins
-index f0eada9..3ab27e2 100644
+index 3ab7c1c18..8c707252e 100644
--- a/Makefile.plugins
+++ b/Makefile.plugins
-@@ -119,3 +119,11 @@ plugins_sixaxis_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
+@@ -110,3 +110,11 @@ plugins_sixaxis_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
-no-undefined @UDEV_LIBS@
plugins_sixaxis_la_CFLAGS = $(AM_CFLAGS) -fvisibility=hidden @UDEV_CFLAGS@
endif
@@ -24,14 +24,14 @@ index f0eada9..3ab27e2 100644
+plugin_LTLIBRARIES += plugins/service.la
+plugins_service_la_SOURCES = plugins/service.c
+plugins_service_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
-+ -no-undefined
++ -no-undefined
+plugins_service_la_CFLAGS = $(AM_CFLAGS) -fvisibility=hidden
+endif
diff --git a/configure.ac b/configure.ac
-index d858ff6..6d31dd3 100644
+index ec810fcf4..173b7f834 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -221,6 +221,10 @@ AC_ARG_ENABLE(sixaxis, AC_HELP_STRING([--enable-sixaxis],
+@@ -328,6 +328,10 @@ AC_ARG_ENABLE(sixaxis, AC_HELP_STRING([--enable-sixaxis],
AM_CONDITIONAL(SIXAXIS, test "${enable_sixaxis}" = "yes" &&
test "${enable_udev}" != "no")
@@ -39,12 +39,12 @@ index d858ff6..6d31dd3 100644
+ [enable service plugin]), [enable_service=${enableval}])
+AM_CONDITIONAL(SERVICE, test "${enable_service}" = "yes")
+
- if (test "${prefix}" = "NONE"); then
- dnl no prefix and no localstatedir, so default to /var
- if (test "$localstatedir" = '${prefix}/var'); then
+ AC_ARG_ENABLE(logger, AC_HELP_STRING([--enable-logger],
+ [enable HCI logger service]), [enable_logger=${enableval}])
+ AM_CONDITIONAL(LOGGER, test "${enable_logger}" = "yes")
diff --git a/plugins/service.c b/plugins/service.c
new file mode 100644
-index 0000000..e63d8a8
+index 000000000..3a236dffe
--- /dev/null
+++ b/plugins/service.c
@@ -0,0 +1,44 @@
@@ -91,7 +91,7 @@ index 0000000..e63d8a8
+}
+
+BLUETOOTH_PLUGIN_DEFINE(service, VERSION, BLUETOOTH_PLUGIN_PRIORITY_DEFAULT,
-+ service_init, service_exit)
++ service_init, service_exit)
--
-2.2.0
+2.17.1