aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-test/recipes-graphics/wayland/wayland-ivi-extension_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test/recipes-graphics/wayland/wayland-ivi-extension_%.bbappend')
-rw-r--r--meta-ivi-test/recipes-graphics/wayland/wayland-ivi-extension_%.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-ivi-test/recipes-graphics/wayland/wayland-ivi-extension_%.bbappend b/meta-ivi-test/recipes-graphics/wayland/wayland-ivi-extension_%.bbappend
new file mode 100644
index 0000000..d1d9fbb
--- /dev/null
+++ b/meta-ivi-test/recipes-graphics/wayland/wayland-ivi-extension_%.bbappend
@@ -0,0 +1,20 @@
+#
+# for testing
+#
+DEPENDS += " gtest"
+EXTRA_OECMAKE += " -DBUILD_ILM_API_TESTS=1 -DINSTALL_ILM_API_TESTS=1"
+
+do_install_append() {
+ install -d ${D}/opt/tests/${PN}
+ mv ${D}/${bindir}/*test ${D}/opt/tests/${PN}
+}
+
+PACKAGES += "${PN}-test"
+DEPENDS_${PN}-test = "${PN}"
+
+FILES_${PN}-dbg += " \
+ /opt/tests/${PN}/.debug/* \
+ "
+FILES_${PN}-test = " \
+ /opt/tests/${PN}/* \
+ "