summaryrefslogtreecommitdiffstats
path: root/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend')
-rw-r--r--meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend b/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend
new file mode 100644
index 0000000..c9ccacc
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/node-startup-controller/node-startup-controller_%.bbappend
@@ -0,0 +1,19 @@
+#
+# for test
+#
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+SRC_URI_append += " \
+ file://helper.zip \
+ "
+
+do_install_append() {
+ install -d ${D}/opt/tests/${PN}
+ install -m 0755 ${WORKDIR}/helper/*.sh ${D}/opt/tests/${PN}
+ install -m 0644 ${WORKDIR}/helper/*.service ${D}/${systemd_unitdir}/system
+}
+
+FILES_${PN}-nsm-dummy += " \
+ /opt/tests/${PN}/* \
+ ${systemd_unitdir}/system/example.service \
+ ${systemd_unitdir}/system/hello.service \
+ "