aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend')
-rw-r--r--meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
new file mode 100644
index 0000000..c09d607
--- /dev/null
+++ b/meta-ivi-bsp/recipes-kernel/linux/linux-yocto_3.10.bbappend
@@ -0,0 +1,25 @@
+PRINC := "${@int(PRINC) + 2}"
+
+# find defconfig path
+FILESEXTRAPATHS := "${THISDIR}/${PN}"
+
+# Kernel configs
+SRC_URI_append_beagleboard = " \
+ file://beagle_qemu.cfg \
+ "
+
+SRC_URI_append_vexpressa9 = " \
+ file://vexpress_a9.cfg \
+ "
+
+SRC_URI_append_qemux86 = " \
+ file://qemux86.cfg \
+ "
+
+SRC_URI_append_qemux86-64 = " \
+ file://qemux86_64.cfg \
+ "
+
+KMACHINE_vexpressa9 = "beagleboard"
+SRCREV_machine_vexpressa9 ?= "${AUTOREV}"
+COMPATIBLE_MACHINE_vexpressa9 = "vexpressa9"