aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.build67
-rw-r--r--README.md76
2 files changed, 78 insertions, 65 deletions
diff --git a/README.build b/README.build
new file mode 100644
index 0000000..0d1ca38
--- /dev/null
+++ b/README.build
@@ -0,0 +1,67 @@
+Build a QEMU image that contains GENIVI components
+--------------------------------------------------
+
+You can build a QEMU image that should be GENIVI compliant using the
+following steps:
+
+1. Export TEMPLATECONF to pick up correct configuration for the build
+export TEMPLATECONF=PATH_TO_META_IVI/meta-ivi/meta-ivi/conf
+
+2. Run the following command:
+ > $ source poky/oe-init-build-env
+
+3. Build a s/w image including GENIVI 13.0 (Orion) components
+ > $ bitbake orion-image
+
+4. Run the emulator:
+ > for qemu vexpressa9:
+ > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu -m vexpressa9
+ >
+ > for qemu x86:
+ > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu -m qemux86
+ >
+ > for qemu x86-64:
+ > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu -m qemux86-64
+ >
+ > for qemu qemuarm64:
+ > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu -m qemuarm64
+
+5. To login use these credentials:
+ > User - root
+ > Password - root
+
+
+update poky, meta-openembedded by script
+----------------------------------------
+1. confirm current directory is meta-ivi
+ > $ basename `pwd`
+ meta-ivi
+
+2. run script
+ > $ ./scripts/checkout
+
+
+Build a s/w image with audiomanager 7.0 instead of 7.4
+------------------------------------------------------
+Because audiomanagerplugins 7.4 is not working properly,
+ you may choose audiomanager/plugins 7.0
+ as an implementation of audiomanager 7.0 specification.
+( see https://at.projects.genivi.org/jira/browse/AMP-1 )
+
+to use am 7.0, put following lines to <build directory>/conf/local.conf
+# use audiomanager 7.0 until am7.4 issues are fixed.
+PREFERRED_VERSION_audiomanager ?= "7.0"
+PREFERRED_VERSION_audiomanagerplugins ?= "7.0"
+
+
+Build s/w packages using gstreamer1.0-\*\_1.2.3.bb instead of default version
+-----------------------------------------------------------------------------
+you may encounter a build error like below:
+
+ERROR: Nothing PROVIDES 'tremor' (but /opt/genivi-baseline_13/poky/../meta-ivi/meta-ivi/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bb DEPENDS on or otherwise requires it)
+ERROR: Required build target 'gstreamer1.0-plugins-base' has no buildable providers.
+Missing or unbuildable dependency chain was: ['gstreamer1.0-plugins-base', 'tremor']
+
+then you may need "tremor" package for build this package.
+add following line to your conf/bblayser.conf.
+BBLAYERS_append := " <your topdir>/meta-openembedded/meta-multimedia"
diff --git a/README.md b/README.md
index fbfa65f..bf7ff52 100644
--- a/README.md
+++ b/README.md
@@ -5,23 +5,18 @@ This layer's purpose is to add In-Vehicle Infotainment (IVI) support when
used with Poky. The goal is to make the Yocto Project reference system
Poky GENIVI compliant.
-Please see the
-[MAINTAINERS](https://github.com/GENIVI/meta-ivi/blob/master/MAINTAINERS)
-file for information on contacting the maintainers
-of this layer, as well as instructions for submitting patches.
-
The meta-ivi project welcomes contributions. You can contribute code,
submit patches, report bugs, answer questions on our mailing lists and
review and edit our documentation and much more.
+[Wiki page](https://at.projects.genivi.org/wiki/display/PROJ/meta-ivi).
+[Mailing list](https://lists.genivi.org/mailman/listinfo/genivi-meta-ivi).
+[report Bugs](https://at.projects.genivi.org/jira/projects/BASE/).
-Subscribe to the mailing list
- [here](https://lists.genivi.org/mailman/listinfo/genivi-meta-ivi).
-[View or Report bugs](https://at.projects.genivi.org/jira/secure/RapidBoard.jspa?rapidView=10&projectKey=BASE).
-Read the [wiki](https://at.projects.genivi.org/wiki/display/PROJ/meta-ivi).
For information about the Yocto Project, see the
- [Yocto Project website](https://www.yoctoproject.org).
+[Yocto Project website](https://www.yoctoproject.org).
+
For information about the Yocto GENIVI Baseline, see the
- [Yocto GENIVI Baseline wiki](https://at.projects.genivi.org/wiki/display/PROJ/GENIVI+Baselines).
+[Yocto GENIVI Baseline wiki](https://at.projects.genivi.org/wiki/display/PROJ/GENIVI+Baselines).
Layer Dependencies
------------------
@@ -35,6 +30,10 @@ URI: git://git.openembedded.org/meta-openembedded
> branch: pyro
> revision: 5e82995148a2844c6f483ae5ddd1438d87ea9fb7
+URI: git://git://git.yoctoproject.org/meta-gplv2
+> branch: pyro
+> revision: de001bd6bfcec943d274b649c62be6848cc9c3e6
+
Using the above git sha's and the master meta-ivi branch,
bitbaking orion-image is known to work
(the orion-image build should be aligned with GENIVI 13.0).
@@ -42,7 +41,7 @@ Using the above git sha's and the master meta-ivi branch,
For creating a specific GENIVI compliant image version, please make sure you
git checkout the related meta-ivi branch and follow the build instructions
located in the README.md file of that branch. So for example, to build
-an image that should be GENIVI 6.0 compliant, checkout the meta-ivi 6.0 branch,
+an image that should be GENIVI 9.0 compliant, checkout the meta-ivi 9.0 branch,
and follow the README.md part of that branch. As does the GENIVI Alliance
we only support the current and the previous version. Any version older
than that is not supported any more, and therefore may not build or run.
@@ -61,56 +60,3 @@ Please check on our [wiki](https://at.projects.genivi.org/wiki/display/PROJ/meta
regarding any community supported machines.
For example there Renesas provides a public Board Support Package (BSP)
available for use with meta-ivi.
-
-Build a QEMU image that contains GENIVI components
---------------------------------------------------
-
-You can build a QEMU image that should be GENIVI compliant using the
-following steps:
-
-1. Export TEMPLATECONF to pick up correct configuration for the build
-export TEMPLATECONF=/full/path/to/meta-ivi/meta-ivi/conf
-
-2. Run the following command:
- > $ source poky/oe-init-build-env
-
-3. Build a s/w image including GENIVI 13.0 (Orion) components
- > $ bitbake nostromo-image
-
-4. Run the emulator:
- > for qemu vexpressa9:
- > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu -m vexpressa9
- >
- > for qemu x86:
- > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu -m qemux86
- >
- > for qemu x86-64:
- > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu -m qemux86-64
- >
- > for qemu qemuarm64:
- > $ PATH_TO_META_IVI/meta-ivi/scripts/runqemu -m qemuarm64
-
-5. To login use these credentials:
- > User - root
- > Password - root
-
-Build a s/w image with audiomanager 7.0 instead of 7.4
-------------------------------------------------------
-Because audiomanagerplugins 7.4 is not working properly,
- you may choose audiomanager/plugins 7.0
- as an implementation of audiomanager 7.0 specification.
-( see https://at.projects.genivi.org/jira/browse/AMP-1 )
-
-to use am 7.0, put following lines to <build directory>/conf/local.conf
-# use audiomanager 7.0 until am7.4 issues are fixed.
-PREFERRED_VERSION_audiomanager ?= "7.0"
-PREFERRED_VERSION_audiomanagerplugins ?= "7.0"
-
-update poky, meta-openembedded automatically
---------------------------------------------
-1. confirm current directory is meta-ivi
- > $ basename `pwd`
- meta-ivi
-
-2. run script
- > $ ./scripts/checkout