aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-connectivity/portmap/files/portmap.service12
-rw-r--r--recipes-connectivity/portmap/portmap_6.0.bbappend17
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-connectivity/portmap/files/portmap.service b/recipes-connectivity/portmap/files/portmap.service
new file mode 100644
index 0000000..be06edd
--- /dev/null
+++ b/recipes-connectivity/portmap/files/portmap.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Server that converts RPC program numbers into DARPA protocol port numbers
+After=connman.service
+
+[Service]
+Type=oneshot
+ExecStart=/sbin/portmap -l
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/recipes-connectivity/portmap/portmap_6.0.bbappend b/recipes-connectivity/portmap/portmap_6.0.bbappend
new file mode 100644
index 0000000..a8c6ed5
--- /dev/null
+++ b/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -0,0 +1,17 @@
+# Find "files" directory
+FILESEXTRAPATHS := "${THISDIR}/files"
+
+SRC_URI_append_vexpressa9 = " file://portmap.service"
+
+
+PACKAGES =+ "${PN}-systemd"
+
+FILES_${PN}-systemd = "/lib/systemd/system/"
+
+do_install_append() {
+
+ mkdir -p ${D}/lib/systemd/system
+ install -m 644 ${WORKDIR}/portmap.service ${D}/lib/systemd/system/
+
+}
+