aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-connectivity/ofono/ofono.inc33
-rw-r--r--recipes-connectivity/ofono/ofono/ofono42
-rw-r--r--recipes-connectivity/ofono/ofono_1.6.bb15
-rw-r--r--recipes-connectivity/ofono/ofono_git.bb18
4 files changed, 108 insertions, 0 deletions
diff --git a/recipes-connectivity/ofono/ofono.inc b/recipes-connectivity/ofono/ofono.inc
new file mode 100644
index 0000000..104f951
--- /dev/null
+++ b/recipes-connectivity/ofono/ofono.inc
@@ -0,0 +1,33 @@
+HOMEPAGE = "http://www.ofono.org"
+SUMMARY = "open source telephony"
+DESCRIPTION = "oFono is a stack for mobile telephony devices on Linux. oFono supports speaking to telephony devices through specific drivers, or with generic AT commands."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://src/ofono.h;beginline=1;endline=20;md5=3ce17d5978ef3445def265b98899c2ee"
+
+inherit autotools pkgconfig update-rc.d
+
+DEPENDS = "dbus glib-2.0 udev mobile-broadband-provider-info ${@base_contains('DISTRO_FEATURES', 'bluetooth','bluez4', '', d)} ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
+
+INITSCRIPT_NAME = ""
+INITSCRIPT_PARAMS = ""
+
+do_install_append() {
+ if [[ "${DISTRO_FEATURES}" == *"systemd"* ]]
+ then
+ rm -rf ${D}${sysconfdir}/init.d/
+ else
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
+ fi
+}
+
+PACKAGES =+ "${PN}-tests ${PN}-systemd"
+
+FILES_${PN}-systemd += "${base_libdir}/systemd/system"
+FILES_${PN} += "${base_libdir}/udev ${systemd_unitdir}"
+FILES_${PN}-tests = "${libdir}/ofono"
+
+RDEPENDS_${PN}-tests = "python python-pygobject"
+# Systemd service needs systemd
+RDEPENDS_${PN}-systemd = "systemd"
diff --git a/recipes-connectivity/ofono/ofono/ofono b/recipes-connectivity/ofono/ofono/ofono
new file mode 100644
index 0000000..cc99709
--- /dev/null
+++ b/recipes-connectivity/ofono/ofono/ofono
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/ofonod
+PIDFILE=/var/run/ofonod.pid
+DESC="Telephony daemon"
+
+if [ -f /etc/default/ofono ] ; then
+ . /etc/default/ofono
+fi
+
+set -e
+
+do_start() {
+ $DAEMON
+}
+
+do_stop() {
+ start-stop-daemon --stop --name ofonod --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/recipes-connectivity/ofono/ofono_1.6.bb b/recipes-connectivity/ofono/ofono_1.6.bb
new file mode 100644
index 0000000..386ffee
--- /dev/null
+++ b/recipes-connectivity/ofono/ofono_1.6.bb
@@ -0,0 +1,15 @@
+require ofono.inc
+
+SRC_URI = "\
+ ${KERNELORG_MIRROR}/linux/network/${BPN}/${BP}.tar.bz2 \
+ file://ofono \
+"
+SRC_URI[md5sum] = "d863b2b650a525cf75056085398bc8ef"
+SRC_URI[sha256sum] = "63e38ea1cf35b00ecbab7611c6caa2adcd33eb10495f7a9f72013d4ab7a14c98"
+
+
+EXTRA_OECONF += "\
+ --enable-test \
+ ${@base_contains('DISTRO_FEATURES', 'bluetooth','--enable-bluetooth', '--disable-bluetooth', d)} \
+"
+
diff --git a/recipes-connectivity/ofono/ofono_git.bb b/recipes-connectivity/ofono/ofono_git.bb
new file mode 100644
index 0000000..a44b411
--- /dev/null
+++ b/recipes-connectivity/ofono/ofono_git.bb
@@ -0,0 +1,18 @@
+require ofono.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "14544d5996836f628613c2ce544380ee6fc8f514"
+PV = "0.12-git${SRCPV}"
+PR = "r3"
+
+SRC_URI = "git://git.kernel.org/pub/scm/network/ofono/ofono.git;protocol=git \
+ file://ofono"
+
+EXTRA_OECONF += "\
+ ${@base_contains('DISTRO_FEATURES', 'bluetooth','--enable-bluetooth', '--disable-bluetooth', d)} \
+"
+
+do_configure_prepend () {
+ ${S}/bootstrap
+}
+