aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ivi-bsp/conf/layer.conf10
-rw-r--r--meta-ivi-bsp/conf/machine/vexpressa9.conf40
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-ivi-bsp/conf/layer.conf b/meta-ivi-bsp/conf/layer.conf
new file mode 100644
index 0000000..e30882a
--- /dev/null
+++ b/meta-ivi-bsp/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "ivibsp"
+BBFILE_PATTERN_ivibsp = "^${LAYERDIR}/"
+BBFILE_PRIORITY_ivibsp = "7"
diff --git a/meta-ivi-bsp/conf/machine/vexpressa9.conf b/meta-ivi-bsp/conf/machine/vexpressa9.conf
new file mode 100644
index 0000000..8d90e39
--- /dev/null
+++ b/meta-ivi-bsp/conf/machine/vexpressa9.conf
@@ -0,0 +1,40 @@
+#@TYPE: Machine
+#@NAME: vexpress-a9 machine
+#@DESCRIPTION: Machine configuration for the vexpress a9 board
+
+PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
+
+# Ship all kernel modules by default
+MACHINE_EXTRA_RRECOMMENDS = " kernel-modules"
+
+# Allow for MMC booting (required by the NAND-less)
+EXTRA_IMAGEDEPENDS += ""
+
+# Uncomment the following line to enable the hard floating point abi. Note that
+# this breaks some binary libraries and 3D (neither of which ship with
+# meta-yocto). For maximum compatibility, leave this disabled.
+#DEFAULTTUNE ?= "cortexa8hf-neon"
+include conf/machine/include/tune-cortexa9.inc
+
+IMAGE_CLASSES += "sdcard_image"
+
+IMAGE_FSTYPES += "tar.bz2 ext3 vexpressa9-sdimg"
+EXTRA_IMAGECMD_jffs2 = "-lnp "
+
+# 2.6.37 and later kernels use OMAP_SERIAL, ttyO2
+# earlier kernels use ttyS2
+SERIAL_CONSOLE = "115200 ttyO2"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto ?= "3.4%"
+
+PREFERRED_PROVIDER_jpeg = "jpeg"
+PREFERRED_PROVIDER_jpeg-native = "jpeg-native"
+
+KERNEL_IMAGETYPE = "uImage"
+
+UBOOT_MACHINE = "ca9x4_ct_vxp_config"
+UBOOT_ENTRYPOINT = "0x80008000"
+UBOOT_LOADADDRESS = "0x80008000"
+
+MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat alsa"