aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-yocto/qemux86.cfg3
-rw-r--r--recipes-kernel/linux/linux-yocto/vexpress_a9.cfg1
-rw-r--r--recipes-kernel/linux/linux-yocto_3.4.bbappend4
3 files changed, 8 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto/qemux86.cfg b/recipes-kernel/linux/linux-yocto/qemux86.cfg
new file mode 100644
index 0000000..ff828b9
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto/qemux86.cfg
@@ -0,0 +1,3 @@
+# config for adding support for AF_BUS sockets
+CONFIG_AF_BUS=y
+CONFIG_NETFILTER_DBUS=y
diff --git a/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg b/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg
index 09381e6..9222010 100644
--- a/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg
+++ b/recipes-kernel/linux/linux-yocto/vexpress_a9.cfg
@@ -1980,3 +1980,4 @@ CONFIG_ZONE_DMA_FLAG=0
# config for adding support for AF_BUS sockets
CONFIG_AF_BUS=y
+CONFIG_NETFILTER_DBUS=y
diff --git a/recipes-kernel/linux/linux-yocto_3.4.bbappend b/recipes-kernel/linux/linux-yocto_3.4.bbappend
index 5fc1672..1b0ab6e 100644
--- a/recipes-kernel/linux/linux-yocto_3.4.bbappend
+++ b/recipes-kernel/linux/linux-yocto_3.4.bbappend
@@ -10,6 +10,10 @@ SRC_URI_append_vexpressa9 = " \
file://vexpress_a9.cfg \
"
+SRC_URI_append_qemux86 = " \
+ file://qemux86.cfg \
+ "
+
SRC_URI += "file://0001-net-bus-add-the-AF_BUS-socket-address-family.patch"
KBRANCH_vexpressa9 = "standard/beagleboard"