aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/poky-ivi-systemd.conf2
-rw-r--r--conf/machine/vexpressa9.conf2
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend11
3 files changed, 1 insertions, 14 deletions
diff --git a/conf/distro/poky-ivi-systemd.conf b/conf/distro/poky-ivi-systemd.conf
index 9ea9efb..065de17 100644
--- a/conf/distro/poky-ivi-systemd.conf
+++ b/conf/distro/poky-ivi-systemd.conf
@@ -7,6 +7,6 @@ VIRTUAL-RUNTIME_initscripts = ""
include conf/distro/include/default-providers-ivi.inc
-DISTRO_FEATURES += " bluetooth systemd "
+DISTRO_FEATURES += " bluetooth systemd opengl "
LAYER_CONF_VERSION = "6"
diff --git a/conf/machine/vexpressa9.conf b/conf/machine/vexpressa9.conf
index 266ff6d..fbfefcb 100644
--- a/conf/machine/vexpressa9.conf
+++ b/conf/machine/vexpressa9.conf
@@ -47,5 +47,3 @@ UBOOT_ENTRYPOINT = "0x80008000"
UBOOT_LOADADDRESS = "0x80008000"
MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat alsa"
-
-DISTRO_FEATURES_append = "opengl"
diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
index fc367af..55fdb5c 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.2.bbappend
@@ -11,14 +11,3 @@ SYSTEMD_AUTO_ENABLE = "disable"
SRC_URI_append = " file://X.service \
"
-
-# If we don't have mesa-dri as virtual/gl we deactivate this support in xserver and
-# remove remove xorg-extension-glx from RDEPENDS as we use OPENGLES and EGL
-python () {
- if ((d.getVar("PREFERRED_PROVIDER_virtual/libgl", True) or "").find("mesa-dri") == -1):
- extraoeconf = d.getVar("EXTRA_OECONF", True)
- extraoeconf += " --disable-glx --disable-dri"
- d.setVar('EXTRA_OECONF', extraoeconf)
- else:
- d.setVar('RDEPENDS_xserver-xorg', "xserver-xorg-extension-glx")
-}