aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb b/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb
new file mode 100644
index 0000000..2263647
--- /dev/null
+++ b/meta-ivi-test/recipes-extended/common-api/capicxx-perf_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Common API C++ test code: measure the performance of message sending"
+SECTION = "tests"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = \
+ "file://${COMMON_LICENSE_DIR}/MPL-2.0;md5=815ca599c9df247a0c7f619bab123dad"
+PR = "r0"
+
+SRCREV = "2eacc9d7fb76957e9a5450a559675fddf0a95ce2"
+SRC_URI = "git://github.com/GENIVI/capic-poc.git"
+S = "${WORKDIR}/git/test/capicxx-perf"
+
+DEPENDS = "common-api-c++ common-api-c++-dbus capicxx-core-native capicxx-dbus-native"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE += "-DCMAKE_INSTALL_PREFIX=/usr"
+
+_installdir = "/opt/tests/${PN}"
+
+FILES_${PN} = " \
+ ${_installdir}/* \
+ "
+
+FILES_${PN}-dbg += " \
+ ${_installdir}/.debug/* \
+ "
+
+do_install_append() {
+ _DEST=${D}${_installdir}
+ install -d ${_DEST}
+ mv ${D}/usr/bin/* ${_DEST}
+ rmdir ${D}/usr/bin
+ rmdir ${D}/usr
+}