aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi/conf/distro/poky-ivi-systemd.conf
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2015-10-01 11:51:10 +0200
committerYong-iL Joh <yong-il.joh@windriver.com>2015-11-10 20:52:31 +0900
commit647889838b7175d687c094f75f55b1c4ddf8aef0 (patch)
tree274d3ffba92fe54e4aea8c4f4dbbb9ddadc6f2cf /meta-ivi/conf/distro/poky-ivi-systemd.conf
parentf997a4b0ced1b5e25d05f4b1fa7c47abf2f49c94 (diff)
downloadmeta-ivi-647889838b7175d687c094f75f55b1c4ddf8aef0.tar.gz
meta-ivi-647889838b7175d687c094f75f55b1c4ddf8aef0.tar.bz2
meta-ivi-647889838b7175d687c094f75f55b1c4ddf8aef0.zip
wayland-ivi-extension: add support for version 1.5.0
- Also adds a backport for Wayland/Weston 1.5.0 ; work in all cases, though. - to keep the API of wayland-ivi-extension, set preferred version to 1.3.0 Signed-off-by: Manuel Bachmann <manuel.bachmann@iot.bzh>
Diffstat (limited to 'meta-ivi/conf/distro/poky-ivi-systemd.conf')
-rw-r--r--meta-ivi/conf/distro/poky-ivi-systemd.conf3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-ivi/conf/distro/poky-ivi-systemd.conf b/meta-ivi/conf/distro/poky-ivi-systemd.conf
index f67f17f..285ceeb 100644
--- a/meta-ivi/conf/distro/poky-ivi-systemd.conf
+++ b/meta-ivi/conf/distro/poky-ivi-systemd.conf
@@ -34,6 +34,9 @@ PREFERRED_VERSION_gstreamer1.0-plugins-ugly ?= "1.4.%"
PREFERRED_VERSION_gstreamer1.0-libav ?= "1.4.%"
PREFERRED_VERSION_gstreamer1.0-omx ?= "1.2.%"
+# to keep the compatibility of wayland-ivi-extension
+PREFERRED_VERSION_wayland-ivi-extension ?= "1.3.0"
+
POKYQEMUDEPS = "${@bb.utils.contains("INCOMPATIBLE_LICENSE", "GPLv3", "", "packagegroup-core-device-devel",d)}"
DISTRO_EXTRA_RDEPENDS_append_qemuarm = " ${POKYQEMUDEPS}"
DISTRO_EXTRA_RDEPENDS_append_qemux86 = " ${POKYQEMUDEPS}"