aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_4.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_4.14.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.14.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.14.bb b/recipes-kernel/linux/linux-intel-rt_4.14.bb
index 0611304c..6967ec25 100644
--- a/recipes-kernel/linux/linux-intel-rt_4.14.bb
+++ b/recipes-kernel/linux/linux-intel-rt_4.14.bb
@@ -5,7 +5,7 @@ require linux-intel.inc
# to build multiple virtual/kernel providers, e.g. as dependency of
# core-image-rt-sdk, core-image-rt.
python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
+ if d.getVar("KERNEL_PACKAGE_NAME", True) == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
}
@@ -17,8 +17,8 @@ SRC_URI_append = " file://0001-perf-x86-32-explicitly-include-errno.h.patch"
DEPENDS += "elfutils-native openssl-native util-linux-native"
-LINUX_VERSION ?= "4.14.106"
-SRCREV_machine ?= "5cfa4c85d15168b84e40bd38b7d31a62a01e40d3"
+LINUX_VERSION ?= "4.14.134"
+SRCREV_machine ?= "09a421a9b2ba044daf4ab9ea2f54a33cf7a2fac1"
SRCREV_meta ?= "bc35d5bd224ab031440a69f9806d839db382f05c"
LINUX_KERNEL_TYPE = "preempt-rt"