aboutsummaryrefslogtreecommitdiffstats
path: root/meta-n450
diff options
context:
space:
mode:
Diffstat (limited to 'meta-n450')
-rw-r--r--meta-n450/conf/machine/n450.conf2
-rw-r--r--meta-n450/recipes-bsp/audiofix/audiofix.bb17
-rw-r--r--meta-n450/recipes-bsp/audiofix/files/n450_audiofix13
-rw-r--r--meta-n450/recipes-bsp/n450-audio/n450-audio.bb23
-rw-r--r--meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio15
5 files changed, 40 insertions, 30 deletions
diff --git a/meta-n450/conf/machine/n450.conf b/meta-n450/conf/machine/n450.conf
index eda91d9d..c06cb6cb 100644
--- a/meta-n450/conf/machine/n450.conf
+++ b/meta-n450/conf/machine/n450.conf
@@ -11,3 +11,5 @@ APPEND += "console=ttyS0,115200 console=tty0"
PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto-stable"
+# Ensure the bsp packages are installed
+MACHINE_EXTRA_RRECOMMENDS += " n450-audio "
diff --git a/meta-n450/recipes-bsp/audiofix/audiofix.bb b/meta-n450/recipes-bsp/audiofix/audiofix.bb
deleted file mode 100644
index 3b1d2723..00000000
--- a/meta-n450/recipes-bsp/audiofix/audiofix.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Provide a basic init script to enable audio"
-DESCRIPTION = "This package provides an init script which enables the audio on startup via the amixer command. It address a problem with the development board that has the audio muted on power on."
-SECTION = "base"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
-PR = "r2"
-RDEPENDS = "alsa-utils-amixer"
-
-SRC_URI = "file://n450_audiofix"
-
-do_install () {
- install -d ${D}${sysconfdir}/init.d
- install -d ${D}${sysconfdir}/rc5.d
- install -m 0755 ${WORKDIR}/n450_audiofix ${D}${sysconfdir}/init.d
- ln -sf ${D}${sysconfdir}/init.d/n450_audiofix ${D}/${sysconfdir}/rc5.d/S91n450_audiofix
-}
diff --git a/meta-n450/recipes-bsp/audiofix/files/n450_audiofix b/meta-n450/recipes-bsp/audiofix/files/n450_audiofix
deleted file mode 100644
index 9ec04482..00000000
--- a/meta-n450/recipes-bsp/audiofix/files/n450_audiofix
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-AMIXER=`which amixer`
-
-if [ ! -e $AMIXER ]; then
- if [ -e /usr/bin/amixer ]; then
- AMIXER=/usr/bin/amixer
- else
- echo "No amixer, so unable to reset Front channel ON"
- fi
-fi
-
-
diff --git a/meta-n450/recipes-bsp/n450-audio/n450-audio.bb b/meta-n450/recipes-bsp/n450-audio/n450-audio.bb
new file mode 100644
index 00000000..20e3a9ad
--- /dev/null
+++ b/meta-n450/recipes-bsp/n450-audio/n450-audio.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Provide a basic init script to enable audio"
+DESCRIPTION = "Set the volume and unmute the Front mixer setting during boot."
+SECTION = "base"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PR = "r3"
+
+inherit update-rc.d
+
+RDEPENDS = "alsa-utils-amixer"
+
+SRC_URI = "file://n450-audio"
+
+INITSCRIPT_NAME = "n450-audio"
+INITSCRIPT_PARAMS = "defaults 90"
+
+do_install() {
+ install -d ${D}${sysconfdir} \
+ ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/n450-audio ${D}${sysconfdir}/init.d
+}
+
diff --git a/meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio b/meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio
new file mode 100644
index 00000000..ad1b0bd4
--- /dev/null
+++ b/meta-n450/recipes-bsp/n450-audio/n450-audio/n450-audio
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+AMIXER=`which amixer`
+
+if [ ! -e "$AMIXER" ]; then
+ if [ -e /usr/bin/amixer ]; then
+ AMIXER=/usr/bin/amixer
+ else
+ echo "amixer not found, unable to set default audio settings."
+ exit 1
+ fi
+fi
+
+# Enable the "Front" simple controls (black phones jack)
+$AMIXER sset Front 30 on