aboutsummaryrefslogtreecommitdiffstats
path: root/meta-n450
diff options
context:
space:
mode:
Diffstat (limited to 'meta-n450')
-rw-r--r--meta-n450/conf/machine/n450.conf32
-rw-r--r--meta-n450/recipes-kernel/linux/linux-yocto_3.0.bbappend9
2 files changed, 37 insertions, 4 deletions
diff --git a/meta-n450/conf/machine/n450.conf b/meta-n450/conf/machine/n450.conf
index f9cf4f2a..888c5d2e 100644
--- a/meta-n450/conf/machine/n450.conf
+++ b/meta-n450/conf/machine/n450.conf
@@ -3,13 +3,37 @@
#@DESCRIPTION: Machine configuration for Intel 1-N450 based systems
-require conf/machine/atom-pc.conf
+include conf/machine/include/tune-atom.inc
+
+MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \
+ acpi serial"
+
+KERNEL_IMAGETYPE = "bzImage"
+
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+PREFERRED_VERSION_linux-yocto = "3.0+git%"
+PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
+PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim"
+PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri"
+PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite"
+PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite"
+XSERVER ?= "xserver-xf86-dri-lite \
+ xf86-input-mouse \
+ xf86-input-keyboard \
+ xf86-input-evdev \
+ xf86-input-synaptics \
+ xf86-video-intel \
+ mesa-dri-driver-i915"
SYSLINUX_OPTS = "serial 0 115200"
SERIAL_CONSOLE = "115200 ttyS0"
APPEND += "console=ttyS0,115200 console=tty0"
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-yocto"
+MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts n450-audio"
+
+IMAGE_FSTYPES ?= "ext3 cpio.gz live"
+
+GLIBC_ADDONS = "nptl"
+GLIBC_EXTRA_OECONF = "--with-tls"
-# Ensure the bsp packages are installed
-MACHINE_EXTRA_RRECOMMENDS += " n450-audio "
+ROOTLESS_X = "1"
diff --git a/meta-n450/recipes-kernel/linux/linux-yocto_3.0.bbappend b/meta-n450/recipes-kernel/linux/linux-yocto_3.0.bbappend
new file mode 100644
index 00000000..c1b69aab
--- /dev/null
+++ b/meta-n450/recipes-kernel/linux/linux-yocto_3.0.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+COMPATIBLE_MACHINE_n450 = "n450"
+KMACHINE_n450 = "yocto/standard/common-pc/atom-pc"
+
+# The n450 is a single core hypterthreaded CPU
+KERNEL_FEATURES_append_n450 += " cfg/smp.scc"
+
+SRCREV_machine_pn-linux-yocto_n450 = "c54453332efbd86c2ea3caa64e908b39cfac1e76"
+#SRCREV_meta_pn-linux-yocto_n450 ?= XXXX